Enscape for Revit - "Error starting Enscape: Value cannot be null"

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Hi,


    I am using Enscape for Revit 2024 which was working perfectly last week, however, since launching today I have been receiving the attached error. I cannot send a report through when prompted as as soon as I start to edit the fields on the next page, Revit just locks up and crashes.

    I have tried updating my graphics drivers, reinstalling Enscape, and restarting my PC. Nothing seems to address the issue.

    I have a fairly powerful PC with RTX 2080Ti, Windows 11, Intel i9-9900KF Processor so I doubt it's a hardware compatibility issue.

    Any help please let me know.

    • Official Post

    I'm sorry to hear about that - In this case if you cannot submit a feedback report itself, please manually share the following log files with our support team:


    Enscape main plugin log files:

    C:\Users\%USERNAME%\AppData\Roaming\Enscape\Data\Logs


    Revit plugin log files:

    C:\Users\%USERNAME%\AppData\Local\Temp\Enscape\Logs\EnscapeRevitPlugin


    You can just put those files in a .zip folder and send it via our dedicated Help Center as detailed here. You'll be assisted shortly thereafter once we had a chance to check out the logs themselves. Feel free to also let me know once it's submitted as well, thank you in advance!


    Meanwhile, you can also try a full re-install of Enscape and just so you know, our latest release can always be (re-)acquired here.

  • I am still having this issue. I first tried to uninstall and reinstall Enscape. The issue persisted. We have tried detaching and auditing the central model. On my machine, the issue persists. On my coworker's machine, upon opening the file, he gets a combination of schema errors (attached), BUT can open Enscape. Every time he purges the schemas available to purge, they come right back after saving and reopening the file.


    I am in Revit 2024 by the way, and both me and my coworker are using the latest enscape.

    • Official Post

    Thank you everyone for the reports. Our developers have been made aware of these problems as well of course to see if there's anything we can do ourselves or if our hands are tied here for now.


    Allow me to share what the main problem is here as well, quoted from the Autodesk forum post detailing these issues and offering some (hopefully temporary) workarounds:

    Quote

    What's the New Problem

    "The new problem seems to relate to Revit files that are upgraded to 2024/2024.1. The 11 July Revit 2024.1 release notes show that in there were changes made to the API to try and fix an outstanding schema condition. It feels like that change may have created some new conditions. We have an open case with Autodesk on this issue.

    There are three new Autodesk solutions that suggest that to avoid the problem you need to upgrade your pre-2024 files one at a time to avoid a crashes, deleted data, or the error dialog prompt.

    I am hopeful that these are just interim workarounds to a problem that will be fixed. We have not changed our Ideate Software schemas and yet our customers are experiencing this issue."

    As already linked by rifkin , you can also check out the main Autodesk post here as well.


    I'll keep you posted in case of any further information or updates soon.

  • Suffering from this exact problem too.


    EDIT: Logfiles are attached - even giving those is not straightforward. :(


    EDIT 2: This was the solution for me: https://help.autodesk.com/view…25-449B-84D0-8241EA15849A


    1. Launch a new session of Revit.
    2. Open/Upgrade one model.
    3. Save the upgraded model.
    4. Close Revit.

    Lost the work I'd made, but at least I could start again.

  • After installing one of the last updates, I started getting this dialogue when I open many of my files. It says the following information:


    Schema Conflict when Loading a File.


    The file contains data of schema "DataStorageUniqueld" (front""), which has the same ID as a different shcema already in memory. If the file is loaded, the existing data will be erased from the model.


    It gives me the option to:


    Do not load the file

    Cancels the File Load operation.


    Continue loading the file

    Data in the existing schema with the same ID will be erased from the model.


    All the research I have done says it that this error has to do with a third-party plugin that is installed. The only third-party plugin that I have is Enscape.


    Enscape or not, can anyone help me with this?

  • Hi guys, this is the error:

    [Blocked Image: https://forums.autodesk.com/t5/image/serverpage/image-id/1270511i88E64F1CC5708373/image-size/medium?v=v2&px=400]

    This is my revit version:

    [Blocked Image: https://forums.autodesk.com/t5/image/serverpage/image-id/1270512i4B12E22D54284F4E/image-size/medium?v=v2&px=400]

    When I choose "continue loading..." it still crashes.

    And i have a project to deliver next week =/

    Any ideas guys, please?

    Thanks.

    • Official Post

    To update anyone in this thread who wasn't aware yet: There has been another update provided by Autodesk: Revit 2024.1.1 which seems to fix the schema upgrade issue. In that regard we can thus only advice using that version instead of Revit 2024.1.0 for example.


    This is detailed once more here:

    https://ideatesoftware.com/blo…4-1-and-new-schema-errors


    And via the Autodesk homepage itself including further solutions if this still occurs with 2024.1.1:

    https://www.autodesk.com/suppo…ueId-in-Revit-2024-1.html


    I hope this helps. alessandroj, ABayley I've merged your existing posts from a new thread into this thread as it involved the same topic, just to avoid any confusion.


    Please let me know in case anyone still experiences any further problems thereafter.

    • Official Post

    I have been using Revit 2024.1.1 since the day it was released on September 5th. It did not fix my issues.

    I'm sorry to hear about that.


    Just to make very sure, have you also tried the following proposed additional steps from the Autodesk website that should help with resolving this?


    Allow me to copy a corresponding excerpt with what's particularly of interest marked red:

    Quote

    2024.1.1

    • Update: The Revit 2024.1.1 update should prevent element deletion or crashes caused by schema conflicts for newly created models or models upgraded from versions prior to 2024.

    Ensure everyone is updated to 2024.1.1.

    • Old Data: The update will not resolve conflicts introduced in Revit 2024.0 / 2024.0.1 / 2024.0.2 / 2024.1.
    • New Conflicts : If a schema conflict shows up for models upgraded/created with 2024.1.1, click the ‘Continue loading the file’ option to move forward.

    Note: Depending on the schemas involved, selecting the option to continue loading the file could lead to the deletion of model elements.

    Model Modified before 2024.1.1

    If the model was upgraded / modified in a 2024 version before 2024.1.1, and encountering the schema conflict, use one of the following options to get the model into a good state:

    • Re-upgrade model: If the model was recently upgraded from a prior version, re-upgrade the model from the prior version (for example 2023, 2022...) to the 2024.1.1 (or later) version.
    • Recover backup: If the conflict shows up after working/saving for a period of time in 2024.0 / 2024.0.1 / 2024.0.2 / 2024.1 versions of Revit, go through the following steps to see if there is a good backup that can be used:
    1. To get a good copy of the model schemas, upgrade an old version of model (prior to 2024) to 2024.1.1 or later version and save a copy of model for this process. This step is important as the conflict relates to two schemas, and this gives a good copy for Revit to compare against when opening backups.
    2. With the newly upgraded model open check if a backup copy of the model can be found/opened without the conflict.

    In that regard please make sure that the projects of yours are updated to version 2024.1.1 as well and alongside if that may not do the trick, please also simply try to "click the ‘Continue loading the file’ option to move forward.". Or does that actually still remove certain model elements?


    Kindly let me know and if you're unsuccessful then also submit us a feedback report with log files as detailed here. Even though this behavior is not directly caused by Enscape, it would still be good to receive said report to analyse and forward.

  • Yes, I have upograded and resaved the files. I always have to "click the 'Continue loading the file' option to move forward.

    When I get this message, it does not crash, and I can continue after clicking the "Continue Loading the File" option.

    My Revit has been more prone to crashes beyond this dialogue, and I don't know if it's related.

    Either way, it's just a pain to have to click this dialogue every time I open a family or project with this issue.

    • Official Post

    Yes, I have upograded and resaved the files. I always have to "click the 'Continue loading the file' option to move forward.

    When I get this message, it does not crash, and I can continue after clicking the "Continue Loading the File" option.

    My Revit has been more prone to crashes beyond this dialogue, and I don't know if it's related.

    Either way, it's just a pain to have to click this dialogue every time I open a family or project with this issue.

    I see, thanks a lot for your quick reply.


    In that regard our hands will very likely be tied for now until another fix is introduced from their side. I'm fully aware that this error message is annoying to say the least, but if the second option (Continue to load file) does not remove any models or such from your scene or has any other unwanted side effects otherwise then we can only reccomend using that workaround as suggested by Autodesk.


    Regarding the more frequent crashes with Revit itself, you can still feel free to submit that feedback report for us to check if this may be related to Enscape or not. If you decide to do so, you can just include a link to this thread for reference in the feedback's submission form.

  • Thanks for the reply.

    When you say: "try to upgrade the model to version 2024.1.1" the only thing that comes to my mind is simply to open the file using your updated Revit version, or is there another way? Because that was what I was doing.

    Because what happened was: i created my model and site plane on Revit 2024 (don't know which version it was, but it was before the 24.1.1) and all of sudden i was getting the enscape material schema conflict and "continue loading the file" was not working. Then I did some research and updated to 24.1.1 but I think everything got worse apparently.

    Anyways, I reached out autodesk troubleshooting customer service and sent the guy a copy of my problematic files and he said everything was fine, he sent them back to me and they are working fine but I still get the same schema conflict but now if i choose " continue loading the file" it works and it doesn't seem there's something missing.

    So my theory is that once the troubleshooting guy opened (and maybe saved the file) he actually updated the version of that models (but it should've happened after updating my Revit as well).

    Thanks.