Synchronized View render mismatch with Matched Photo in Sketchup with Enscape v3.4.0 - v 3.5.3

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Matched Photo / Photomerge


    v3.4.0 - v 3.5.3 Renders doesn't match with the sketchup viewport using Synchronized View when the sketchup scene is from a matched photo.


    This is not an Issue on v.3.3.1

    Assuming that the Reference Photo (Photomerge.PNG) was matched properly in sketchup.


    Render settings:

    1. Visual Settings> Output > Resolution : Must be equal to the Reference Photo or equivalent Aspect Ratio

    2. Synchronize Views prior to Rendering.


    The output render will match the Reference Photo when layed over on each other even if:

    a. The Sketchup viewport ratio is not the same as the ratio of the reference photo.

    b. The Sketchup Viewport ratio is the same as the ratio of the reference photo.

    c. The Sketchup Viewport ratio is the same as the ratio of the reference photo with a Linked Visual Preset.

    This doesn't matter even if the Scene was originaly created with v 3.3.1 or v 3.4-v3.5.


    Findings:


    For Photomatched Scenes Only (Scenes created using Sketchup>Camera>Match New Photo)


    In V3.5.3, When rendering with Synchronized View, Visual Settings>Main>Camera>Projection returns to Two-Point.

    even if it is set to Perspective before Sync view is turned ON. See Issue.PNG


    In V3.3.1 the Camera Projection becomes Perspective when Sync View is turned On even if the it set to Two-Point when NOT using Sync View.


    This has been an case after the implementation of Camera Settings (Position, Orientation) under View management when linking a Visual Preset. V 4.0 Onwards.

    Attached Files
    1. Issue.PNG
    2. Sketchup Screen Grab.PNG - Photomatched reference photo in Sketchup
    3. Photomerge.PNG - Reference Photo
    4. Pmerge 3.5-Resized Viewport-Sync Off-Layed over Result.png - Enscape Render that is layed over on the reference photo using Photoshop. Sync OFF. Normal
    5. Pmerge 3.5-Resized Viewport-Sync ON-Layed over Result.png - Enscape Render that is layed over on the reference photo using Photoshop. Sync ON. ISSUE
    6. Pmerge 3.3-Resized Viewport-Sync Off-Layed over Result.png - Enscape Render that is layed over on the reference photo using Photoshop. Sync OFF. Normal
    7. Pmerge 3.3-Resized Viewport-Sync ON-Layed over Result.png - Enscape Render that is layed over on the reference photo using Photoshop. Sync ON. CORRECT

    • Official Post

    Egrojeca , thank you very much for your comprehensive post, I really do appreciate the effort.


    I'll of course be investigating this and will forward everything accordingly to our developers for further review.


    You'll hear back from me once I have any further news/info to share thereafter.

  • Hi All,


    I have exactly the same problem now in the newest version 4.0.0.579 Enscape. In version 3.3.1 everything works perfectly and every version since then changing the perspective to 2 point perspective when synchronize views option is on. The problem is only when u use match photo in Sketchup. Could you please do investigation and fix that issue in latest version as I have to use version 3.3.1 to render properly the photomontages.


    Kind regards,

    Robert

  • Hello, i have the same problem with enscape! i have few hours to finnish project and this is big problem!

    I have found that manually changing the SketchUp Field of View (under Camera) can help resolve this. For example, if I have a scene that has a FOV of 38.5° and Enscape is not matching the view properly, I will manually change the FOV to 38.499999°. For whatever reason, Ensacpe then matches the new FOV and the scene itself is not altered in anyway.


    Sometimes I can then save the new FOV as a new scene and Enscape will continue to match that scene properly.