Broken lighting with Enscape 3.5.3+117852 and raytracing on AMD gpu

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Hi,


    I reported this problem by email yesterday and am sharing it here in case it is widespread. Since installing Enscape 3.5.3+117852 (6 September 2023), shadows are completely black. Enscape is thus unusable. See captures attached. The problem disappears if I switch off raytracing altogether. The "Ultra" quality is also significantly slower than before.


    I'm using an AMD Radeon Pro W6800X with the latest driver from AMD, on a Mac Pro 2019, Revit 2023, Windows 10.


    I've reverted to the previous Enscape version (3.5.2+112393) for the time being.


    Thank you,


    Jf

    • Official Post

    Thanks a lot jflemay for the report.


    Is there any chance you've used a different e-mail to submit this problem to our support team as well? If you haven't, please definitely also send us a dedicated feedback report including logs as detailed here: https://learn.enscape3d.com/bl…back-button-win-sketchup/


    If you've already done so, then it would be great to receive the e-mail you've used (via a DM) just so I can look up the report as well.


    Thanks a lot in advance once more.

    • Official Post

    Hello jflemay - I'm sorry to hear that you haven't gotten a response back via the feedback report you've submitted. As of now using the e-mail you've provided me I can only find your previous inquiries, the last being a crash report from July 26 this year. Since you mentioned that you received an outdated GPU driver warning e-mail (which should be normal in this case) to which you replied back, it is unusual that you got no reply back at all.


    In that regard, since you received this automated e-mail though, I wanted to make sure that you've also acquired the latest drivers from this page here: https://www.bootcampdrivers.com/


    If you did so already, then it's likely that there isn't anything we can do here as we also rely on these specific driver updates to be rolled out to Windows on Mac users for compatibility. In general, using Bootcamp in combination with Enscape was not something we were ever able to officially support or fully reccomend due to this reason alone. In case you are using the latest drivers, I can at this point thus only suggest turning of ray-tracing if it resolves this problem.


    I'm sorry for not having more positive news, but once more, Bootcamp and Enscape is not something we can fully support currently (or perhaps ever) and there may always be some incompatibility issues regardless of outdated GPU drivers even. Regarding the slowdowns when your Visual Settings are set to Ultra, this may be due to our improved global illumination system, which usually does not require much more performance compared to 3.5.2, but again this behavior may also be an incompatibility caused side effect.


    Still, since I couldn't locate the current feedback report of yours, please feel free to submit another just so we can at least go through the logs and so forth to see if there's anything we can do, which even if unlikely please also kindly reach out again after you've hit the Submit button. This allows us to ensure we'll also properly receive any additional future reports.


    Thanks a lot in advance.

  • Hi Demian, I've just reported it using the Enscape Feedback button, with the email address info@jflemay.com, could you confirm that you received it? Thank you.


    "Automation Update AMD driver - Broken lighting with Enscape 3.5.3+117852 and raytracing on AMD gpu / 01505076 / [ ref:_00D0Y1IeF9._500JzBQI7s:ref ]"

    • Official Post

    Hi Demian, I've just reported it using the Enscape Feedback button, with the email address info@jflemay.com, could you confirm that you received it? Thank you.


    "Automation Update AMD driver - Broken lighting with Enscape 3.5.3+117852 and raytracing on AMD gpu / 01505076 / [ ref:_00D0Y1IeF9._500JzBQI7s:ref ]"

    Thank you for your quick reply. I'm afraid, we still do not receive the reports as we should from your machine. I'll make sure to further investigate why this is happening.


    Meanwhile, please kindly send us your Mac log files manually then:


    You will have to make hidden files visible in the Finder. To do this make sure that you are in the Finder (see if “Finder” is written in the top left, next to the Apple symbol) and hit “Command” + “Shift” + “.” together once.


    Then go to Macintosh HD -> users -> [your user folder] -> Library -> Application Support -> Enscape -> Data -> Logs


    Kindly copy the files/most recent file in this folder and send them in via our Help Center as detailed in the second half here, and simply let me know once again after submitted. Ideally, please also include a link to this thread for reference.


    After you have send the log file to us you can set the visibility of hidden files back to its usual state by pressing “Command” + “Shift” + “.” together once more while in the Finder. Hidden files should now be invisible again.


    Again, thanks a lot and you'll hear back from me in case there are still any problems with receiving inquiries from your e-mail (this time via the Help Center).

  • Hi Demian,


    Thank you for the quick reply. I've submitted a ticket (number 154805) and hope the team can help. I will consider installing a driver from BootCampDrivers, although for now I prefer to use the official ones provided by AMD at this address:


    https://www.amd.com/en/support…ase-notes/apple-boot-camp


    I included an Enscape log file which I found in this location on my Mac:


    C:\Users\(my user name)\AppData\Roaming\Enscape\Data\Logs


    Thank you,


    Jf

    • Official Post

    Thank you very much, it really is appreciated.


    Right away, we did receive the ticket/case and everything attached, but I'm afraid unfortunately as expected the log file does not contain any error messages that could lead to any solutions or further conclusions in terms of resolving this issue of ray-tracing not working properly with your setup, besides that we can still only advice to turn that functionality off for the time.


    The last thing which comes to mind is to disable "NVIDIA Global Illumination Denoiser" and "NVIDIA Shadow Denoiser" while keeping only "Ray-Traced Sun Shadows" active. But I reckon you've very likely tried that previously too of course.


    Still, if you have any further questions regarding this topic or any other, let me know whenever please.

  • Hi Demian,


    Global illumination is still broken with Enscape 3.5.5 when ray-tracing is on. See screen captures attached, comparing to Encape 3.5.2 which worked perfectly with ray-tracing.


    This is running on Revit 2023, Windows 10 latest version, Intel Xeon 28-core processor, with the AMD Radeon Pro W6800X professional graphics card. The computer build is a 2019 Apple Mac Pro.


    I will report this as a ticket. It would be great if you could fix it - I don't want to stay stuck with 3.5.2 forever.


    Thank you,


    Jf

    • Official Post

    Hello jflemay , I've sent you another reply with further inquiries regarding your Boot Camp drivers and receiving a fresh set of log files. Feel free to reply back through the case itself via e-mail as well. I appreciate the cooperation and further response in advance.

  • Dear Demian Gutberlet , thank you, I will give the BootCampDrivers a try. You are right that the latest ones released officially by AMD for my graphics card are 21.30, whereas the latest from BootCampDrivers are 23.20. I am wary of installing unofficial drivers but I will give it a try eventually. Until then I'll stick to Enscape 3.5.2. Thank you.

  • Dear Demian Gutberlet and Enscape team, I'm happy to report that using the latest drivers from BootCampDrivers (October 2023, version 23.9.3) as opposed to the official ones from AMD's page (which are 21.30), and the latest version of Enscape 3.5.6, has fixed the raytracing. Enscape images look great, and walk-through and VR headset performance are back to excellent. Raytracing makes a big difference in shadow and reflection accuracy.


    For the record my computer set-up is Apple Mac Pro 2019, Boot Camp, Windows 10, Revit 2023 and AMD Radeon Pro W6800X.


    Thank you for your help.


    Jf