Mirroring Bug - Revit

  • Hi Enscape Team,


    First, I want to say thank you for creating the Asset Library. It's going to be very useful.


    That being said I ran into a problem when I mirror Elements from the Asset Library in the Revit. I didn't experience this issue in Sketchup or Rhino.


    I brought in various elements and mirrored them over the center axis. I did this a few times with slight differences orientations because.

    I was getting inconsistent results this morning when I a was actually trying to mirror elements. I later started noticed that depending on the direction the element was facing before mirroring, it will glitch out in a slightly different way (or at-least that's what I think is happening).


    On the left we have Revit and the right we have Enscape. The Mirror Axis line is down the center of the image, left side being the original and the right side being the mirrored elements.


    Attempt 1 - (click spoiler to see image)

    Gabriela is facing the same direction after being mirrored

    Picture Frame Portrait is facing the same direction after being mirrored

    Minotti Sofa appears to have been rotated 180 Degrees

    Stacked Cupboard appears to have been rotated 180 Degrees

    ___


    Attempt 2 - (click spoiler to see image)

    Gabriela 1 and 3 are facing the same direction

    Gabriela 2 and 4 appear to have been rotated 180 Degrees


    ___


    Attempt 3 - (click spoiler to see image)

    In this attempt I rotated each individual original Gabrielas 45 degree counter clock wise then mirrored them

    It appears all elements that were facing left are still facing left and if they were facing right they are still facing right

    BUT if they were facing down they are facing up and if they were facing up they are not facing down



    Hope this helps identify and solve this bug