Batch Render not Respecting Aspect Ratios?

  • I'm having an issue where if I do a standalone rendering (using the hotkey), my settings for image resolution work fine, whether a preset or a custom resolution. Then with the same exact settings in place, a batch render of starred views will come out cropped slightly tighter, cutting off some of the image all around, but not in a predictable way. It's frustrating because it takes a long time to compose the views only to have to export one at at time in order to preserve those compositions.


    Any ideas? Is this aspect ratio of the batch renderer just something that we'll need to wait for a fix on? Sorry if I'm missing something basic.

    Otherwise we are all in love with the software and latest updates! Kudos to the team.

  • Any ideas? Is this aspect ratio of the batch renderer just something that we'll need to wait for a fix on? Sorry if I'm missing something basic.

    Which software you are using? From Rhino it's a known problem that the viewport size ratio determinate the output. So, if you come back after some days and your Rhino UI has changed a little bit, so you get an other output. If I understand right there is the same problem for SU. At Rhino it help to check the viewport size and if needed to set it to the previous used size. At Rhino you can setup a some commands for the screen capture button to automatic keep the viewport size.

  • I'm using the Revit version.


    I now typically just make Enscape views to "bookmark" the angles, and then use the standalone capture to save the image, in order to save the aspect. As I mentioned, the batch render seems to crop the images slightly. I also tried widening the field of view to compensate for the crop, but it's still cropping...

  • I just had the same issue yesterday. It was actually my first attempt at using Batch Render. Enscape for Revit version 2.4.0.385.

  • Batch render tool is a false friend, it's not working like expected at Rhino too - the different lens length of the saved views is ignored, the lens length of the first batch rendered view is used for all views . I don't used it anymore.

  • rypat , @Clemson, thank you for your patience, would you please be so very kind as to briefly send me a .zip file for example which contains a bunch of correctly rendered batch exports, alongside ones which are falsely cropped? You can upload the .zip (or .rar) here.


    Also, just to make sure I understand everything correctly, but you adjust the Enscape window to a size which is corresponding to the output resolution (correct aspect ratio as well), so that the renderings look identical or very similar to the real-time output, correct? You export some renderings manually via hotkey, the aspect ratio is correct, but once you use the batch render function some come out different looking compared to the real-time output? :)


    Micha , thanks for your feedback as well. I'm afraid, the lens length of the Rhino camera (if that is what you're speaking about) is not saved in views, I can file it as a feature request though. Let me know if I'm missing something or in case you're using a different approach. ;)

  • Hi Demian Gutberlet a typical workflow at Rhino is, the user save views at Rhino and render them later. The lens length is saved to the Rhino views. The global Enscape FoV option is disabled, since Enscape is using the Rhino FoV. That's fine.

    Enscape allow me to choose which of the Rhino views should be rendered during batch rendering and start a batch render process. Enscape reads the Rhino views. And now the FoV is ignored. From an users view it's a bug, since the batch functionality is useless.


    What is needed? If the user choose which Rhino views should be rendered by the batch process, than Enscape needs to read the FoV too and not only the camera positions. All informations are saved in Rhino, but Enscape reads a part only. It's a communication problem.


    And if we want to make it perfect, than Enscape should read the Rhino camera target and use it for the depth of field focus. That's the standard of all Rhino render engines, no engine needs a manual set focus target.


    I would be very glad if this basic functionality could be supported. The problem is reported some months before and I hope a fix is possible. I afraid on the long run only a feature request makes not happy. ;)