Navigation / hand controller elements not showing up in Enscape (Sketchup)

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • On Vive, the nav elements show up, but I can't see anything from my pointer (right) hand. No circle, no menu pointer. Has anyone else had this issue? Was working fine a week or more ago. Also I'm not seeing the hand controllers, which I think were there before?

    • Official Post

    shoogydoo , as far as I understand, the right controller generally does not work in Enscape, but in other applications it does? If you haven't tried to see if this problem is persistent in other applications as well, could you kindly do so? :)


    If this behavior is only reproduceable in Enscape, could you please send us some feedback through the Feedback button? Please add your forum name, or the title of this thread as reference in the submission form. That would be very helpful to find out the cause behind this issue. Thank you in advance!

  • Sorry for being quiet on this for a bit, but I am still having this issue. This appears to be a bug in seeing the UI elements. I exported my scene to an executable and confirmed they reappear on a different machine, so this is something to do with my particular setup. They used to be there, but now I don't see them. I've tried reinstalling both Enscape and Sketchup, but am still having the same issue. Since I can't take a picture of what's not there, here's a screen shot from another video of what I am not seeing, circled in red. The missing yellow target is particularly frustrating because new users have no idea why they are jumping way farther than they expect when they can't see the target. Any ideas?


    Thanks for your help!

    • Official Post

    Hey shoogydoo , happy to hear back from you. :)


    It may be helpful, if you could kindly do that, to completely reinstall/redo the corresponding HTC Vive setup alongside Steam VR and so on. If that doesn't help, would you be so kind as to send in some feedback as mentioned (from the machine with which you experience these issues) above in my last reply? :)


    This will transfer all the Enscape log files from your machine to us which should very well help us to get behind the cause of this behavior.


    Thank you so much in advance!

  • Hello shoogydoo,


    we get the controller models form Steam VR. There are many reasons why the controller may not turn up. Either the hardware you use does not have registered controllers or there is a bug in SteamVR and reinstalling may fix the issue.


    Furthermore, there may be a tracking issue. The yellow teleport indicator should and menu always be there. even without controller. I will investigate this and get back to you.

  • Just another update to this issue. I sent through my data using the feedback button, but there wasn't anything obvious there that the devs could work with. I noticed I had an old EXE that I had exported ages ago, that had the models appearing correctly on another machine. I tried opening the old exe on the machine that I was having issues with, and suddenly, the models and reticle was appearing fine! Fixed! Well.... until this last update. Now I'm missing my controller models and teleportation reticle again and the exe trick I used before no longer works. I'm stuck again.


    This is super frustrating to navigate being an experienced user, and near impossible to explain to an inexperienced client trying VR for the first time - that they have to point the controller towards the ground in front of them, then pull the trigger without any understanding where they are jumping to or why they might be blocked.


    Anyhoo. Stuck again. I'm surprised I'm the only one having this issue. Help?

    • Official Post

    Hey shoogydoo , in that case, could you kindly completely re-install SteamVR and Enscape? If that doesn't help at all, please kindly send in a further report after the latest release has been installed again. Thank you very much in advance!

  • Our set up just started having this issue today. Our right controller won't transport us around. We see the white-blue laser and the controller itself, but it doesn't do anything when I pull the trigger. I will try a re-install of Steam and Enscape. If that doesn't fix it, I will send feeback.

  • cholden424 Please make sure in a different VR application that your controller's button is not stuck / dud. It may as well be a hardware issue.