VR quality issue with custom visual presets

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Hi,


    I'm experimenting with VR and visual presets.


    I have two Enscape scenes set up, one with Ultra quality, the the other as draft quality with outlines.


    Enscape loads with the Ultra quality preset, it loads into VR fine. If I change scene (currently via Sketchup) then the visual settings update to the lower quality visual style - so far so good. The issue comes when I try and switch back to the Ultra quality preset, the resolution seems to drop and the VR image is very noisy with pixel smearing. The only way to resolve this is to untoggle the VR headset option in Enscape and then retoggle it. See image below


    It matters because I need clients to be able to switch back and forth between the two visual presets.


    Using Sketchup 2023 and Enscape 3.5.6+202715


    Thanks for any help.


    Oh and as an additional to this - in VR presentation mode, whilst the view location changes fine when choosing a favourite scene, the visual presets do not update correctly, I assume that's not currently possible?


    • Official Post

    BarryFishFinger , thanks a lot for the report.


    In essence we have already identified the cause behind this behavior and will be providing a fix as soon as we can with a future service pack / preview. I'll also notify you once that further update is made available.


    Regarding your question: When you're in VR presentation mode, settings such as rendering quality stay constant. This mode is mainly designed for moving between locations, as changing quality settings in that mode each time during use may also introduce stuttering, which we aim to prevent, especially within VR. Of course, as usual any future wishes related to this topic can also be forwarded via our portal as detailed here in case you would like to see us adjust this.

  • Hi Demian Gutberlet , hope you're well - was there any updates on a fix for this issue? This one:


    Quote

    The issue comes when I try and switch back to the Ultra quality preset, the resolution seems to drop and the VR image is very noisy with pixel smearing. The only way to resolve this is to untoggle the VR headset option in Enscape and then retoggle it.