Meta Quest 3 not working with Enscape

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Paid over 500 euros for the new Meta Quest 3 and the official Link Cable to implement VR into projects.

    I've read on the forum that Steam and SteamVR are no longer required, so I'm trying to start the VR view through the official "Oculus" app but it's not working.


    I'm connected to the laptop with the Meta Link Cable. Laptop is connected to Internet through WiFi but I deliberately turned off WiFi from settings in the headset, to make sure it uses the Link Cable.


    • Test shows 2.4Gbps of transfer speed through the cable

    • CPU: i9 13th generation

    • GPU: NVIDIA RTX 4070 8 GB RAM

    • RAM: 32 GB


    I click on the VR button, and it stays on the "Looking for Headset" forever and apparently doesn't see the headset... Moreover, the second I click on the button, the headset starts lagging and stuttering very badly.


    I was able to make this work in the past with SteamVR, but all that time I thought it was using the Link Cable, however I realized today, it was on WiFi all that time and the cable was only acting as a charger... SteamVR doesn't work without internet, is that correct? I cannot use the Cable with SteamVR.


    Then I found out you don't need SteamVR anymore and I tried to run Enscape through the Oculus app, but it was still using the SteamVR app from within Oculus. So I uninstalled SteamVR from the laptop.


    Now I can't even start the VR in Enscape... Someone please help.

    Enscape and SketchUp are all latest versions.

  • ViggoPaulman

    Changed the title of the thread from “Meta Quest 3 not working with Enacape” to “Meta Quest 3 not working with Enscape”.
    • Official Post

    Hi ViggoPaulman , congratulations on your purchase right away and I'm of course sorry to hear you experience these problems.


    First things first could you perhaps also make very sure that you're using an USB 3 port to connect your headset, and be aware that there's also a way to use the Quest 3 wireless if your router supported it in the past already: https://www.meta.com/help/ques…nk/connect-with-air-link/


    Initially as well for wired use you have to also setup your Meta Quest 3 on your machine (NOT via SteamVR anymore), there is a good article going into further detail here (including all of the requirements), to make sure you did not miss out on any of these steps:

    https://gadgetmates.com/how-to…0set%20up%20Oculus%20Link.


    Please also follow this excerpt from our VR knowledgebase article in regards to the Quest (3):

    - Make sure that the latest Oculus runtime has been installed and you’ve followed all the required steps of the Oculus device setup.

    - Open the Oculus App and select Settings. In the General settings section please activate the Unknown Sources option.

    - When you turn on your Oculus you should now be able to see the Oculus Home Scene.

    - Now you can go ahead and enable Enscape’s VR mode via the Enable VR Headset button on the Enscape ribbon.


    Otherwise can you perhaps check if only Enscape does not function either wired or wireless? Maybe other VR applications do not suffer the same problems and recognize the device? Or do you struggle to get the Quest 3 connected and setup with your machine in the first place after following the prior articles?


    In case you still cannot make use of Enscape, as mentioned either wired (via USB 3) or wireless (using Air Link) please also submit us a feedback report with log files from your machine: https://learn.enscape3d.com/bl…sing-the-feedback-button/


    You can simply include a link to this thread for reference or copy/paste what you've written here in your initial post.


    Beforehand it might be worth trying to re-install Enscape, the Oculus App and once more making very sure that your Quest 3 was setup properly using the official application from Oculus.


    Thank you so much in advance for your cooperation.

  • Hello Demian,


    getting back to this thread after the holidays, so firstly, wishing you a very happy new year! 🎉🎇😊

    After a lot of trial and error and experiments, I'm happy to report, that I finally seem to have found the right way to connect to the Meta Quest 3 headset through Enscape.

    Your reply helped as well. In case someone else stumbles upon the same difficulty in the future, leaving my findings here, to make it easier.


    So, some things to really clarify:

    1. You no longer need Steam Link or Steam VR if you want to view your Enscape scenes in VR. The official Meta Quest app (by January 2024 still called "Oculus") is all you need to be able to start a 360 view. No secondary software or plugins required!

    2. Through the Oculus app you can connect your headset to the PC either wirelessly or wired, as you wish. If, however, you have a slow internet connection, or you're using WiFi, I recommend getting a 5 meter long high-speed cable (the official Meta Quest cable or else). Using the cable has a huge advantage to wireless because it essentially "ignores" the processing inside the headset (which is much weaker compared to PC specs). It turns your headset merely into a "viewer" instead not a computing processor, because all the information is rendered/calculated in your PC and transferred through the cable to the monitor inside the headset.

    3. I don't recommend getting a 3 meter long cable, because regardless of its length it's not optimal. Get a 5 meter long cable.

    You want to ensure that (even for static viewing) you are occupying a circular area of 1.5-2 meters in diameter, that is free of any obstacles, purely for making steps. You want to be at least 2 steps away from your desk/PC, to be able to comfortably turn around on the spot without accidentally bumping on something and whether you want it or not, you will instinctively make 1 or 2 steps within your scenes without realizing it. I tried 3 meters for static viewing but it was too short and on more than one occasion the cable jerked me back towards the computer.


    How to Connect and Run

    1. Download and install the official Oculus app on your PC.

    2. Turn on your headset.

    3. In the Quick Settings make sure "Use Air Link" is disabled. Otherwise it will not use the cable.

    4. Turn off WiFi.

    5. Plug in the cable and connect the headset with the PC. If you have the official Meta Quest cable (USB-C to USB-C) make sure the port on the PC you connect to is a thunderbolt/high-speed. The cable can transfer up to 5 Gbps of data. Official tests, however, show a transfer rate of only around 2-2.3 Gbps, which is also more than enough.

    6. Once connected go to Quick Settings again and under "Available PCs" you should see the name of your computer. Set up the connection.

    7. If successful, your Headset will transfer you to the Oculus dimension (grey environment). From there you can click on the Monitor icon to essentially duplicate your PC monitor onto your headset.

    8. Click on the Enscape button to start the software (I do this from within the headset, while projecting the PC monitor into the headset).

    9. Once running, click on the 360° button in Enscape. This will bring up a new window in your headset, which will show on your deck. Click on X to close this window. This is the most important step because the first time Enscape shows up in your headset the quality is horrible. You have to force the headset to close the Enscape window it opened. It will close it but automatically reopen it again (because the 360 button is still pressed in the Enscape menu). When it reopens again, you will notice a vast improvement in viewing smoothness.


    Some additional things:

    • I played with the NVIDIA Control Panel settings, because initially I could not see my PC screen inside my headset. It was all black. Changing some NVIDIA settings helped to fix the problem.

    • I played with the headset frequency and resolution settings. Be careful because changing the frequency, makes the smoothness worse. Turning your head inside a 360 scene becomes jumpy and jagged and impossible to experience.

    • When viewing scenes, don't turn your head around very fast. Even with a cable, the software still has to transfer and render a lot of data on the spot, and depending on the complexity of your scene, this might take some time. Turning around fast, might make Enscape lag for a couple of seconds.


    I will later upload pictures to elaborate on #9. For now, happy to report that everything is working.

    Thank you again Demian! 🙂