Licensse not working in Rhino 7

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Hi, I just bought the floating license for enscape and tried to enter the key in rhino 7. It did nothing.

    says " got error : serviceunavailable " and it does nothing. when i paste the license key it doesn't accept neither rejects.

    need urgent help please.!

    • Official Post

    Hi Rishabh Khurana , and welcome to our Forum.


    We've received your inquiry sent to our support team as well. Does this behavior still persist? And if so, please kindly reach back out to us via the e-mail response you've received in case you still experience issues here.


    Ideally make sure to attach an additional screenshot as well with your next reply showcasing this specific error message if possible so that we can see it in context with the other menus and such after you tried activating your license key.


    Thanks a lot in advance.