hardware features slowing enscape

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • when I check the ray-traced sun shadows, nvidia shadow denoiser and the Ray-traced artificial light in hardware features it is slowing enscape and make it flickering a lot.

    it is moving again "normal" when unchecked.


    Is it always like this?


    • Official Post

    shotokan , in this regard some slowdown or generally lower than before performance (depending on your graphics card as well) is normal when activating our ray-tracing features. Especially when it comes to the Ray-Traced Artificial Light though please keep in mind that as the disclaimer says, it's still a functionality in experimental state which can cause incorrect rendering or reduced quality.


    Feel free to still of course attach a video example to showcase this flickering you experience and we can check out whether or not this should be normal, especially though in case you may experience visual problems with only Ray-Traced Sun Shadows and NVIDIA Shadow Denoiser enabled which shouldn't happen.


    Thank you in advance for any further replies!

    • Official Post

    What kind of graphics card do you have? Also do you have DLSS enabled? This would help a lot with such a low framerate.

    Ray-traced sun shadows (& artificial lights) are relatively expensive when there are a lot of moving trees/vegetation in the scene. You can also try to set the Wind strength (Atmosphere settings) to 0, which should improve performance as well.
    But ultimately if that doesn't help, I'd suggest to keep the setting off, if you don't encounter any visual quality issues. You could still enable it for your image or video captures if needed though.

    • Official Post

    Ok that explains it :) The 2060 is unfortunately the slowest of Nvidia's desktop RTX line-up and is probably also struggling to fit everything into the 6GB of VRAM with ray traced sun shadows, especially with animated wind (which costs a lot of memory in fact).

    As mentioned, in that case I would just recommend to keep the setting off.

    An upgrade to the latest RTX4000 series will eventually give you a nice performance boost though :)

  • Ok that explains it :) The 2060 is unfortunately the slowest of Nvidia's desktop RTX line-up and is probably also struggling to fit everything into the 6GB of VRAM with ray traced sun shadows, especially with animated wind (which costs a lot of memory in fact).

    As mentioned, in that case I would just recommend to keep the setting off.

    An upgrade to the latest RTX4000 series will eventually give you a nice performance boost though :)

    hello Clemens,


    I'm currently dealing with the 5% load and crash issue with Enscape. But just going into settings to check if I had hardware raytracing and DLSS turned on or not I notice that my settings for those are greyed out completely and off. I'm not able to turn either on or off, yet I am using a RTX 4000 series card. Does that sound odd to you?

    • Official Post

    If you don't see the hardware ray tracing options then it's a clear indicator that the Vulkan driver installation is broken on your machine.
    I believe this is what Demian Gutberlet also already mentioned in another post. This is unfortunately a known issue with certain laptops in the recent past due to an automatic software update.

  • I think we figured it out yesterday based on seeing these settings greyed out and Demian hearing of this, so thanks for reminding me/us of these crucial settings. Turns out I had some portion of an old nvidia driver hung on my machine that had to get cleared up before new drivers would fully install. Options for using DLSS and ray tracing returned to normal and my 5% load crash issue also ended after the clearing and driver upgrade yesterday. Thanks for your response, but it looks like it was unrelated to the windows compatibility update issue others ran into even though I was having quite similar issues.

  • Ok that explains it :) The 2060 is unfortunately the slowest of Nvidia's desktop RTX line-up and is probably also struggling to fit everything into the 6GB of VRAM with ray traced sun shadows, especially with animated wind (which costs a lot of memory in fact).

    As mentioned, in that case I would just recommend to keep the setting off.

    An upgrade to the latest RTX4000 series will eventually give you a nice performance boost though :)


    Is there a performance improvement to be had by changing wind speed to 0? Or is the very presence of the animated assets themselves (regardless of them moving) going to cause an issue?

    • Official Post

    Is there a performance improvement to be had by changing wind speed to 0? Or is the very presence of the animated assets themselves (regardless of them moving) going to cause an issue?

    There are also a performance gains when you set the wind speed to 0, yes. How noticeable they are depends on the number of animated assets and settings like ray-traced sun shadows/artificial lights. For ray-tracing a so called acceleration structure is needed for each animated asset and if the geometry changes the acceleration structure of each individual asset has to be continuously updated, which causes noticeable overhead.