Previous Release / Preview macOS Threads Merged

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • Hi Demian, I has been unsuccessful when it comes to get the Custom Asset to work

    I have tried the 3 different formats (the .gltf I did from Blender) I have 3 days remaining on my trial version today.

    Can you guide me or point out a guide that will guide me step by step (or an existing asset that I can test this with..)?


    "Only the file formats; *.gltf, *.obj or *.fbx can be imported to the Custom Asset Library. As these constitute the most common cross-platform industry standard formats, a model that can be converted to one of these formats can, in theory, be imported into the Custom Asset Library."


    Regards - Lasse

    • Official Post

    There are known issues with asset editor on mac which should be fixed in one of the upcoming preview releases.

    • Official Post

    Dear Forum Community,


    We've just released our latest Enscape for Mac 4.0 Preview 4!


    NEW:

    Collaborative Annotation Mode

    Use this tool to efficiently collaborate with others and share notes about concrete elements of your project. The Collaboration tool can be used with locally stored projects or in conjunction with Newforma Konekt projects (which is a web-based issue tracking platform for BIM coordination).


    Notification Window for New Releases

    Enable this feature through the Enscape General Setting window and stay tuned for the latest updates and new releases.


    UPDATE:

    New UI Theme & Icons


    Texture Editor UI Updates

    Albedo texture transformation is always explicit, while all other texture slots could use, either explicit texture transformation, or the values assigned to the Albedo texture transformation.


    BUGFIXES:

    Fixed Camera Jumps When First Clicking in the Renderer Window

    There was an issue that could cause the camera to jump when first clicking in the renderer window after starting it. This has been fixed.


    Fixed Custom Asset Editor Inside of Enscape Not Opening When Not Configured


    Fixed Batch Rendering Not Working With Default Output Folder


    Fixed Keyboard Shortcuts for Scale and Translate Asset Library Tools


    KNOWN ISSUES:

    Browse Custom Assets Area Is Inaccessible After Project Create or Edit

    The Browse Custom Assets option within the project Create or Edit view is broken and replaced by a non-functional button. Please close and reopen the editor window to access it.


    Errors Are Logged During Assets Selection



    To see what has been added with Enscape for Mac 4.0 Preview 3 check out our prior announcement post here.


    If any questions or further feedback arises, please let us know via this thread or by reaching out to our support. In case your experience any crashes, freezes or similar, kindly submit a feedback report with log files if possible.

    • Official Post

    Dear Forum Community,


    We've just released our latest Enscape for Mac 4.0 Preview 5!


    BUGFIXES:

    • Rhino – Enscape Crashes After Adding .dds Texture
    • SketchUp – Layer Visibility Does Not Get Applied While Batch Rendering
    • Browse Custom Assets Area Is Inaccessible After Project Create or Edit
    • Errors Are Logged During Assets Selection

    To see what has been added with Enscape for Mac 4.0 Preview 4 check out our prior announcement post here.


    If any questions or further feedback arises, please let us know via this thread or by reaching out to our support. In case your experience any crashes, freezes or similar, kindly submit a feedback report with log files if possible.

  • Demian Gutberlet


    I was using the Mac 4.0 Preview 4 (not 5 as stated above) yesterday without issue. Today I now have what looks like a graphics issue. Reported a ticket #217961


    You can see the full-color screenshot of SketchUp, vs the grey screenshot of Enscape. I've also included the version of SketchUp and Enscape. Let me know if you need anything else to diagnose this issue.


    Restarting SketchUp/Enscape did not solve the issue. Nor did restarting my computer. Ventura 13.6.2


    Update 1 : When I closed out of the SketchUp model, leaving the Enscape window up, the render fixed itself (last screenshot) but of course, this doesn't let me work on the model.


    On a very important side note, pressing the Space bar for fly/walk mode does not work, mind you it hasn't worked for some time.


    Update 2: I reinstalled an older version (Escape version - 2.1.0) and I had the same grey render issue so I figured maybe my model was the problem. So I copied/pasted all model contents into a new SketchUp file and relaunched the Enscape render window in 2.1.0 and the render was now working as expected. Then I reinstalled Enscape Mac 4.0 Preview 4 and now the render works on the new SketchUp file but not the original one I was having issues with.


    Update 3: Problem solved! Ok, so the issue was that I moved some folders on my computer which broke the link to the Skybox file in the Visual Settings panel—which in turn dramatically changed the rendering style given the exposure settings without a Skybox. I didn't get a warning regarding this from the Enscape app so I thought there was an issue with the Mac 4.0 Preview. So although this issue has been resolved, and there is no problem with Mac 4.0 Preview, it did bring up a need for triggering a user pop-up alert when the link to a Skybox file has been broken. Adobe Illustrator handles this very well, and would be a good template to follow: when you open a file where the image links are broken it immediately alerts the user.

  • So although this issue has been resolved, and there is no problem with Mac 4.0 Preview, it did bring up a need for triggering a user pop-up alert when the link to a Skybox file has been broken. Adobe Illustrator handles this very well, and would be a good template to follow: when you open a file where the image links are broken it immediately alerts the user.


    There's a pop-up for when the link to the default folder for rendering folder breaks, which would work well for alerting when the Skybox link breaks.

    • Official Post

    Dear Forum Community,


    We've just released our latest Enscape for Mac 4.0 Preview 5!


    BUGFIXES:

    • Fixed on Cause of Random Crashes During Rendering
    • Fixed Missing Artificial Lights on Some Surfaces
    • Fixed Changes in Light Parameters That Were Not Correctly Reflected in Renderer Window
    • Fixed Occurrence of Conflicting Changes of Enscape Assets Included in Components/Groups With Multiple Instances
    • Fixed Custom Asset Editor Not Terminating
    • Fixed Custom Asset Materials Cannot Be Replaced on Geometry Re-Import
    • Fixed Multi Asset Placement Area Was Still Visible After Switching to Collaborative Annotation or BIM Mode
    • Fixed Black Texture Preview in Enscape Material Editor When Brightness Is Less Than 100%
    • Fixed Orbiting Glitches

    KNOWN ISSUES:

    • SketchUp – Geometry Updates Not Working After Importing Model With Materials
      After adding Models with materials, the live updates to the Enscape renderer stop working. This can be remedied by restarting the renderer. Fixed in SketchUp 2024.
    • Rhino 8 – Enscape Freezes when Switching Views
      Fixed in Rhino 8 SR5.


    To see what has been added with Enscape for Mac 4.0 Preview 5 (and prior) check out our prior announcement post here.


    If any questions or further feedback arises, please let us know via this thread or by reaching out to our support. In case your experience any crashes, freezes or similar, kindly submit a feedback report with log files if possible.

  • I cannot install on rhino 8 Mac. it says it installs and I restart and then rhino does not detect any plug in. folders are created in the /library/chaos and library/chaosgroup folders. they look to contain the rhino plug in but it does not load. please help.

    • Official Post

    I cannot install on rhino 8 Mac. it says it installs and I restart and then rhino does not detect any plug in. folders are created in the /library/chaos and library/chaosgroup folders. they look to contain the rhino plug in but it does not load. please help.

    Welcome to our Forum.


    Right away, please make sure that you're using both our latest preview 6 found here in combination with Rhino 8.3 (Service Release 3 or later) in case you haven't updated yet.


    If that does not do the trick, then please also reach out to our technical support team directly using the Help Center as detailed here. You'll then receive a further response from one of our Mac specialists after further troubleshooting.


    Thank you in advance for your cooperation.

  • How can we download this?

    My Enscape has stopped working (I keep getting the message "Error starting Enscape. Enscape has closed unexpectedly etc etc") so I really need this new version with the bug fixes please!

    • Official Post

    Hi Davey , thanks for your post and welcome to our Forum.


    Right away you can always acquire our latest preview of Enscape for Mac here.


    At the moment though our support team is still waiting for a dedicated feedback report which they've requested last Friday. Could you kindly check your e-mails for this reply from us and/or submit a report as detailed here right away? You do not have to have Enscape running to submit that report.


    Thanks a lot in advance, your cooperation is appreciated!

    • Official Post

    Hi pethersonlopes , and thanks for your inquiry.


    Right away to get a general understanding as to why this happens please check out our dedicated FAQ article here.


    And an excerpt of interest right away:

    "Our algorithm prefers to select those objects that have the most impact on lighting in the scene, so sometimes certain elements (especially highly detailed, small objects) might not be visible in this simplified version of the scene. The simplified scene reflections may display lower resolution versions of the materials textures on quality level high."


    We're still working on further improving reflections on Enscape for Mac as well, though currently this behavior is to be expected due to natural limitations of Enscape being a real-time renderer as well.


    Just so you're aware though, using a dedicated Windows machine with a ray-tracing capable GPU would yield better reflection results given that we're able to utilize this technology (ray-tracing) to further help with providing more realistic sun-shadows plus improved shadows cast by artificial light sources (the latter only using our preview on Windows).


    Again, just purely for your information as I reckon of course you will want to remain on your Mac for the time being. With future machines being released by Apple, we'll also have even more access to any extra performance or even hardware ray-tracing to be utilized eventually as well on Enscape for Mac. There are currently no further specifics I can mention yet though.

  • Hi all,


    I have been trying to install enscape for rhino on my Mac for months now. I did try the most recent wip and am using the latest rhino 7. I am using the m3 max chip on a Mac book pro 2024. I have been working with the support team and they don't seem to have any solutions. Are there any work around that have proven effective?

    • Official Post

    Hi all,


    I have been trying to install enscape for rhino on my Mac for months now. I did try the most recent wip and am using the latest rhino 7. I am using the m3 max chip on a Mac book pro 2024. I have been working with the support team and they don't seem to have any solutions. Are there any work around that have proven effective?

    Hi aalepp and thanks for your post.


    We did receive your inquiry submitted yesterday to our support team and you should've also received a response back at this point already. If trying our latest preview in this case does not do the trick please simply reply back to my colleague Helen and we'll look into this further.


    Once more thank you in advance.

  • Please respond. When I Install the preview on my Mac Studio M2 Max computer, the installer finishes with no errors but the plugin is not found by Rhino. What can I do?