Enscape (Revit on Windows) - does not process lights or shadows on a single machine (other computers process the rendering correctly)

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.

  • Enscape recently stopped rendering shadows and lights on a single computer. (example images above)


    Troubleshooting steps taken so far:

    • Installed latest drivers
    • Ran Enscape on different versions of Revit (23 & 24)
    • Ran Enscape from different users on the machine
    • reinstalled Enscape


    The only noticable difference between the two are the following General Settings, which are grayed-out on the trouble computer (but enabled on the functioning machines):

    • Hardware-accelerated Ray-Tracing
      • NVIDIA Shadow Denoiser
    • NVIDIA DLSS


    Any thoughts on how to restore functionality to Enscape on this machine would be greatly appreciated.



    thanks!

    • Official Post

    Hi micahs and welcome to our Forum.


    First things first, does it make any difference if you try adjusting the "Rendering Quality" in the "Main" tab of our "Visual Settings"? For example to "High" or "Ultra"? And on top of that, what graphics card is built into that machine exactly? Just perhaps you recently upgraded from an older GPU to a more recent one before this occurred?


    Furthermore whenever you generally experience technical problems with Enscape like in this case ideally submit us a feedback report alongside as detailed here. This way we receive all of your machine information (CPU, GPU used plus driver dates) and log files which could be used to troubleshoot this further.


    Let me know once said report has been sent so I can have a look right away and thank you in advance.

    • Official Post

    The only noticable difference between the two are the following General Settings, which are grayed-out on the trouble computer (but enabled on the functioning machines):

    • Hardware-accelerated Ray-Tracing
      • NVIDIA Shadow Denoiser
    • NVIDIA DLSS

    In addtion to Demian's comment:
    If these options were available before on the same hardware this points to a potential driver installation issue. You might want to completely remove and re-install your graphics drivers.

  • Thank you all for the responses! I attempted a reinstall of the drivers without success - all the options remain greyed out, and the rendering still does not process light correctly.

    A Feedback ticket was sent out as requested from Revit.


    This machine is a desktop running a GTX 1650 graphics card, and until recently we have had success in using Enscaope. We are using "High" and "Ultra" rendering quality.


    On only this machine, Enscape may render basic materials but struggles with the lighting. The image on the left was the desktop rig giving us trouble, and the image on the right was rendered using a laptop with a mobile graphics card from the same file.


    • Official Post


    This machine is a desktop running a GTX 1650 graphics card, and until recently we have had success in using Enscaope. We are using "High" and "Ultra" rendering quality.


    On only this machine, Enscape may render basic materials but struggles with the lighting. The image on the left was the desktop rig giving us trouble, and the image on the right was rendered using a laptop with a mobile graphics card from the same file.


    Thanks for the update, this was important information. Now it's pretty clear why the hardware ray tracing settings are not enabled: The GTX 1650 does not support hardware ray-tracing.
    So there's nothing to "restore" on this machine as it cannot run these features in the first place. You will therefore not get identical results on both machines, unless you disable hardware ray-tracing on the other. But as you've observed the lighting accuracy is much better with it.


    What you can do to get more similar results is look for the "Ambient Brightness" setting (Atmosphere tab -> Illumination) and reduce that significantly and set the Quality Level to "Ultra". While with hardware ray-tracing we can calculate many light bounces correctly, without we have to fallback to simpler calculations utilizing the "Ambient Brightness" so enclosed rooms don't look too dark. Also make sure to check the exposure settings.

    Hope that helps!