Scale/Proportions in VR incorrect.

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
    • Official Post

    Hey Prosberg , thanks a lot for your inquiry and welcome to our forum!

    First off, just to make sure, have you already setup the correct mode in the VR Navigation menu:

    If you're sitting set it to "Seated" if you're walking around "Roomscale".

    Should this not help, is there a chance you could please send us a screenshot of Enscape VR for further understanding? :)

  • Hi Demian,

    Thank you for your quick response. Yes, the settings are set to roomscale and walkmode.

    I believe this is related to the eye-height, as described in this post: Eye height

    I have tried many different settings now (this occurs in both the editor itself launched through SketchUp, and also in the .exe -standalone). No matter what the initial height of the VR-headset is, it always the same height - I'm 180 cm, and a 210 cm door seems to be just above my head - I seem too tall when standing up.

    In the .exe -standalone, it is possible to set the "spectator height", however, this has no effect.

    It seems to add some height when standing, as the "seated" mode seems OK.

  • Update: this is related to the "floor position" set in Oculus Rift device settings.

    In order to have to right scale in Enscape, the floor position in Oculus device settings must match the height set in the .exe -standalone.

    I'm 180 cm, and setting the floor height to 160 cm in both settings menu, seems to make the eye-level correct.

    However, this is still not correct, as I'm now feeling like I'm 160 cm in Enscape, which gives a very weird experience. ^^

    So something about the spectator height/floor position for Oculus (or HMD's in general) is not right.

    • Official Post

    Prosberg , thanks a lot for your further feedback! I'll definitely forward this behavior to our developers for further troubleshooting. :) We'll also get back to you once we have any news regarding this.

  • Prosberg The problem with VR is that the system does not know exactly where the floor is relative to the headset. So the current eye height is a guesstimate and may be 10 to 20 cm off. A reliable way to throw Oculus off, is by sitting on the floor while switching VR on or give the headset to a really tall person.

    My advice is to tweak the settings, first in the Oculus device menu and then in Enscape until they feel right. Don't take the values are hard values, more as relative values. I calibrate the values by putting a person from the asset library into the scene and change the values until I can look them level in the eyes.

  • Sean Farrell  Demian Gutberlet - Thanks a lot for both of your responses.

    Sean Farrell - I've tested exactly what you are describing, but getting these settings correct is practically impossible - even placing the headset on the ground to begin with doesn't change anything - it is locked to the height set in the Oculus device settings.

    Please note that these things doesn't translate well to a normal screen, so taking a screenshot is not of any great help - I have therefore made to pictures, that should help to explain this, see attachments.

    Picture 1: By entering for example 180 cm in the Oculus settings, the height becomes +20 cm (200 cm total) - as you also stated - but with this setting, the scale/proportions are way off - for example a door being 3 cm thick, looks about 1 cm - very strange phenomenon.

    Picture 2: By entering 160 cm in the Oculus settings (which gives approx. 180 cm in total) the scale/proportions are better, but still not quite correct. But now the perceived ground level in VR is off, giving the feeling the perceived ground level is +20 cm,

    Note - changing the spectator-height in the .exe -standalone does not have any affect.

    This could be related to the interpupillary distance (IPD) - please see this Reddit post, which discuss this issue -…plain_ipd_scaling_issues/

    But as many people also state in this Reddit post, the player height should be determined with proper tracking.

    I've never seen any other VR-apps that lets you adjust the "spectator height", as is the case in the .exe -standalone.

    Thank you for your time. :)

  • Prosberg I created a ticket for you and we will look into the issue. Maybe we can improve setting up VR in Enscape. Thank you for your effort, it helps us developers make more informed decisions on how to improve the software.

  • We looked into the issue and after some research and experimenting, the initial setup of your VR devices is crucial. In the case of Oculus, you need to work through the entire setup procedure every time you move the sensors. (We move the sensors often since we developers are sharing the different VR hardware.)

    The key point it to correctly set the persons height that is calibrating the setup. This value is used to determine the floor height relative to the sensors. Further it helps to have the sensors separated at least 1m. (This value may be different, depending on how far your play area is from the sensors.)

    To validate your setup, a quick test is to place a box in your CAD that is at eye level. If the top of box is at eye level when you wear the HMD and the bottom just slightly below eye level when you lay the HMD on the ground your setup is correct.