Enscape 4.0 Released

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
    • Official Post

    SU has crashed 4 times today trying to insert an ENS microwave

    As I'm not able to reproduce any crashes using this specific asset please also submit a report to our support team as detailed here, ideally whenever you experience any technical problems with Enscape, especially when it comes to crashing.


    This way we can further analyze the exact cause behind this problem, thank you in advance.

    • Official Post

    Discovered inconvenience in 4.0: in order to enter numbers, it is necessary to place the cursor in the input field, after which only you can enter data.

    My apologies in advance if I'm missing the obvious but to which input fields do you refer to exactly? And you're saying that using a prior release of Enscape 3.x.x did not require you to click on those input fields to enter any data?


    Just so I'm understanding it correctly, thank you. :)

    • Official Post

    Will there be a 4.0 msi installer or instructions for a 4.0 version mass deployment/silent install?

    Thanks for your question!


    While we do not plan to release another .MSI installer anytime soon, please check out our updated knowledgebase article here for further information regarding your inquiry: https://learn.enscape3d.com/bl…nstaller-program-options/

  • My apologies in advance if I'm missing the obvious but to which input fields do you refer to exactly? And you're saying that using a prior release of Enscape 3.x.x did not require you to click on those input fields to enter any data?


    Just so I'm understanding it correctly, thank you. :)

    Demian, thank you very much for the feedback.

    To clarify what we're referring to, I'm sending a video comparing data input between different versions. Data input.mp4

    • Official Post

    Demian, thank you very much for the feedback.

    To clarify what we're referring to, I'm sending a video comparing data input between different versions. Data input.mp4

    The video really is much appreciated, thank you for the taking the time. This has been forwarded to our developers already now for review - I'll certainly let you know in case of any further updates in regards to this soon.

  • To clarify what we're referring to, I'm sending a video comparing data input between different versions.


    Bit off topic,

    but why are so many using the Metall Slider in between ?


    99,9% of Materials we have to deal with are either Dielectrics

    (Like Stone, Wood or Plastics) or Conductors (Metals).

    Everything in between would be a Semi Conductor and I doubt many

    render chip wafers or such things, beside maybe solar cells.


    So the Metall slider should usually be just either On or Off.


    I wonder why even Blender offers a Slider at all for PBR.

    I prefer VRAYs approach of controlling Reflection with IOR settings only.


    Dielectrics have strong and colored Diffuse and weak and non tinted Reflections

    if you look from perpendicular to it (around 5%),

    light can enter the Material (Sub Surface Scattering).

    Usually all dielectrics have a vary similar Reflection behavior.


    Conductors have no Diffuse at all but stronger tinted Reflections. Light will be either

    Reflected or absorbed as it can't enter the Material. Reflection values seen perpendicular

    to face largely vary from about 60-98 %.


    Usually all Materials have 100% Reflection if you look from glazing angles, as long

    as the Surface is not really rough.

    If a Conductor is oxidized or painted, those parts behave as standard Dielectrics,

    means it loses its metallic appearance.



    So are most people effectively rendering Semi Conductors or do I misunderstand the

    Metall Slider ?

    Is this more meant as a fake IOR value slider to control the Reflection amount for

    perpendicular view to a face ?

    (In this case I would set it to around 5 % for Dielectrics and 60 % up to 98 for Silver ?)

  • Thanks for your comment, but it's really off-topic. It was a demonstration of input data errors between different versions.

  • Installed and it all seems good apart from a couple of queries:

    • Had a couple of crashes on a heavy model when rendering a scene. Progress gets to around 6% and then vanishes, no error. Restarting Sketchup and reloading the model seem to resolve it though.
    • Has there been any changes to the quality of VR? The image seems a lot softer, to the point where some hard corners almost look as if they're slightly curved they're that fuzzy? I've not changed any of my VR settings between this and the previous version of Enscape.
  • I have just watched the show reel for this release, at 25 seconds it shows an animated gate, is animated objects a new feature? (I no longer have Enscape due to crashing issues on large scale scenes and terrible animation controls) has the stability improved especially heavy scenes and large scale models?

  • Solo I just noticed that because of your comment, but as of two weeks ago Demian posted this



    So I wonder if that is a preview of a new feature or if there was another way that scene was captured.

    • Official Post

    I have just watched the show reel for this release, at 25 seconds it shows an animated gate, is animated objects a new feature? (I no longer have Enscape due to crashing issues on large scale scenes and terrible animation controls) has the stability improved especially heavy scenes and large scale models?

    There's no object animations except for vegetation (wind). I believe what looks like a moving gate in the video is just the camera rotation and parallax effect due to the gate being close to the camera.


    I'm not sure what caused the stability issues in larger scenes for you, but we did test the release with quite large & complex scenes. For instance the Ray traced sun shadows setting can consume a large amount of VRAM (especially with a lot of vegetation) and this can cause instability. We implemented several optimizations in that regard and memory consumption for vegetation is much reduced now, when you disable wind in your Atmosphere settings.

  • I have 24gb vram and 128gb system ram, yet on a scene that is around a mile long and wide with only Enscape vegetation, wind off it consumes way too much ram, and then eventually it gets stuck and I need to end task in the taskmaster.


    I cannot share the model as it's part of an upcoming TV show.


    • Official Post

    I have 24gb vram and 128gb system ram, yet on a scene that is around a mile long and wide with only Enscape vegetation, wind off it consumes way too much ram, and then eventually it gets stuck and I need to end task in the taskmaster.


    I cannot share the model as it's part of an upcoming TV show.


    Just to make sure could you also kindly share another screenshot of your task manager where we can see how much RAM Enscape is using exactly by heading into the "Processes" tab:


    On top of that how large is the project generally in terms of megabytes and perhaps there is as estimation in regards to how many Enscape vegetation assets you've placed down in total if you're only using specifically those to populate the scene? And could you, since it doesn't hurt, also quickly submit a report so that I can check out all of your log files directly? In case we may require it later on as well this would be ideal to receive.


    Thank you in advance.

  • Unfortunately, this is not possible as I did not renew my subscription and a couple of weeks ago, I uninstalled Enscape due to these issues. I also had to modify the model in order to use with another software.

    I was hoping this issue had been fixed with the new version and especially excited to see animated objects but as you say that was just an illusion.