Lighting too strong and sharp in the rendering

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • I updated the enscape to an new version, then it became like this. I swear I didn't change any material or lighting settings in Revit.

    Can anyone can advise me what's going on with my enscape? I have checked again and again about the visual settings and didn't find any issues. Auto Exposure is on, Artificial light Brightness is normal at 63%. You can see the lighting is too strong, and the shadow is so deep dark.



    This the rendering I did before


    This is the rendering of the same scene right now. the down lighting and the daylighting outside the glass door is way too strong.

    • Official Post

    eocess , welcome to our Forum.


    Generally whenever you experience any issues with Enscape please make sure to also ideally submit a report including log files to our support team as detailed here: https://learn.enscape3d.com/bl…sing-the-feedback-button/


    This way we can check out what settings you're currently using, what hardware is built into your machine exactly and so forth.


    Meanwhile also make sure that your machine still meets our requirements and if so, that your graphics card drivers are fully up to date as well. Please acquire the latest GPU drivers for your card from either NVIDIA's or AMD's homepage respectively.


    Last but not least you can also check if disabling "Hardware-accelerated Ray-Tracing" makes any difference, this option can be found via our "General Settings". Of course if you have a ray-tracing capable card with fully updated drivers this should not be a problem, but for testing purposes.


    Overall if trying the above makes no difference or you still experience problems thereafter simply wait for a response back after submitting said report, this way we get the chance to troubleshoot the cause behind this further before sharing any solution.

  • Thank you very much for your reply. I tried turn off "Hardware-accelerated Ray-Tracing", and immediately everything gets back to normal now. I guess the old version didn't use this ray tracing. Ray tracing can be tricky, it only works when there is plenty of even and diffused artificial lighting and the view is not against the direct sunshine.

  • I had the same problem and the issue was with my families. The ray tracing feature works great but your light source position matters a lot more - if your family has the light source placed incorrectly it's going to amplify the error.


    If you notice in your first picture, you have the same issue with hard edge lighting as well caused by incorrectly made families (and/or you are not using IES light source). The same "harsh edge" is there that shouldn't be there. If you correct your families you'll notice that the ray tracing works a lot better.


    That said the feature still has some issues for me... namely in that in make the render export time impossibly long, especially when doing panoramas. A panorama that would previously take me 1 minute to export now takes almost an hour with this option on. Which is a shame because I get good results from it, but it's unusably bad render times currently. I don't fully understand why it takes so long as it runs and looks perfectly smooth in real time.

    • New
    • Official Post

    Hey skhayward - thanks for reporting the issue. An hour for a panorama? That's indeed an incredible increase in time. I spoke with the devs and we haven't been able to reproduce the issue. Is there any chance you could share the project with us this occurs in?
    (I assume that when you render a panorama in a simple, almost empty scene, it's a lot quicker?)
    Although there might be some slightly longer rendering times with this feature enabled, an hour sounds like there's something wrong. Especially if it takes a minute otherwise. We'd love to explore this further.

  • Hey skhayward - thanks for reporting the issue. An hour for a panorama? That's indeed an incredible increase in time. I spoke with the devs and we haven't been able to reproduce the issue. Is there any chance you could share the project with us this occurs in?
    (I assume that when you render a panorama in a simple, almost empty scene, it's a lot quicker?)
    Although there might be some slightly longer rendering times with this feature enabled, an hour sounds like there's something wrong. Especially if it takes a minute otherwise. We'd love to explore this further.


    Model complexity certainly adds to it but not as much as you think . Even if I turn off all light sources in the model it still goes at the same glacial pace. Color rendering makes it take much longer (perhaps not literally an hour as mentioned but certainly getting up there). White mode is faster but still dramatically slower than before.


    Still images also take awhile but it's really the panoramas that seem to drag.


    I can't share a project with you but I just performed a test in the sample project "Snowdon Towers" that comes with Revit 2024 using the "Residential Lobby" 3D view. The results here mirror the results in my own projects.


    Ultra quality, color, normal panorama resolution selected.


    With ray tracing for artificial light sources:

    118sec to complete the first capture


    With this setting disabled:

    38sec to complete the first capture


    So a little more than 3X longer render times in actuality.


    Performance in real time is identical to before, or at least imperceptible in difference. It really is only when a rendering is done does the render time dramatically shoot up.


    Specs:

    i7 11800H 11th Gen Intel

    16GB RAM

    Samsung 1tb NVME SSD

    Laptop RTX 3060


    EDIT: So some inconclusive testing, I noticed when doing the renders after opening up Enscape fresh things were faster. Not by much but shaved off 10 seconds from the raytrace render time above.