Batch Render & Transparency Layer in exported PNG

  • Hi guys, I don't know if it's been requested before (I searched trello but didn't find anything).


    I'd like to know if it's been planned to add a "transparent background" option for PNG export (very useful for product viz)

    and if it is planned to give the possibility to "batch render" a bunch of images.


    Thank you in advance!!


    PS. I just convinced my firm to make Enscape the official renderer 8o

  • Hey pibuz , the first request is already filed on our agenda! I've given the topic a further upvote through your voice. ;)


    Furthermore, you are in fact already able to batch render a bunch of images by doing the following:


    - Create as many views/scenes as you like (of all your favorite locations)

    - Click "Manage Views" (in your Enscape ribbon/context menu) to open the window which contains an overview all your views/scenes

    - Favorite the views/scenes you want to export a rendering from by clicking the little star icon on the right


    Now, you can just click the following button in the open window:


    This will, as the description says, "Render an image of all favorited scenes." :) So basically, Enscape will transition to a scene, take a rendering, go to the next scene, take a rendering, and so on. Is this what you were looking for? Let me know in case there is anything else I can help you with.

  • No problem what so ever pibuz , I'm here to help. :)


    Exactly, but we have a dedicated feature request on our agenda to allow you to save settings per view, if you like, I'll gladly upvote this topic through your voice.

  • Hi,


    (Sketchup user)


    Thanks for such a great product. I've been using Enscape for approx 2 months, and it's really great.


    Recently I've found this forum thread and tried the "batch render" function, but it does not work as advertised. It just saves images based on the first scene's settings (layers, etc.) then flies through each scene very roughly matching the camera positions of each scene. But this is useless when trying to render views with the ceiling turned on or off and it doesn't not match the camera position in each scene. So, please fix this as soon as possible, it's pretty annoying after I exported many images only to start compositing and realized that the rendered images do not match up with the Sketchup scenes.;(


    Thanks and keep up the good work and I'll keep supporting Enscape!


    :thumbsup:

  • Hey giri-giri , thanks a lot for your feedback and welcome to our forum.


    First off, I've given the corresponding topic to support scene-layers in our batch render functionality a further upvote through your voice, thanks a lot for your feedback.


    Furthermore, to export your images corresponding to SketchUp's view-port (so that the rendered images match up with the Sketchup scenes camera position wise), please try the following:


    Go into the Enscape Settings -> "Capture" tab -> Set Resolution to "Custom" -> Activate "Use viewport aspect ratio" and input (for example) 1920 in the available first custom field, then, adjust the SketchUp's horizontal viewport size until you have a custom resolution of 1920x1080. This resolution is just an example and you can of course use any output resolution you like.


    If you have any further inquires regarding this subject or if something is not entirely clear to you, please let me know!

  • +1 for png renders with clear backgrounds, please! i use enscape with photoshop and it's a PAIN to clean out the white background

    Forwarding your feedback, and a warm welcome to our forum! :)

  • I think this is an old request, but adding my +1 as well.

    Slows down the photoshop workflowing needing to pull from the render channels and mask manually.

    Thank you, added.

  • +1 for PNG Renders with Transparent Backgrounds


    am i too late?? ;( i've not try ii again. Already have? Demian Gutberlet

    _____

    i have the BW rendered image 4k (in 100% Depth) and set into photoshop as masking channel



    and this is what i've got. i did not retouch anyting i've only copy and paste that the rendered depth file and made a mask layer, so i think the problem is on the Depth material image that Enscape done is not very good made even though i've set it to 100% depth, i dont know if it can be improving in the next update so i can make my main rendered image have a good transparancy. Thank You.

  • ElZoel the halo you are seeing is a challenge for many rendering packages, not just Enscape.


    Also, a transparent PNG would not necessarily fix this either. It is possible to save a transparent PNG with Vray + 3DsMax and still end up with halos.


    Right now, you have three options.


    1) In photoshop you can adjust the mask to remove the halo. (I agree this is not ideal, but as I said even with transparent PNG this halo could exist depending on how it is produced by Enscape. )


    2) Use Material ID pass and create mask in photoshop


    3) Render a separate pass to create a mask - First render with everything on, Then turn off everything except what you want to create a mask for.


    In the future, hopefully Enscape can save with transparent background AND allow compositing without a halo. The Enscape team will need to code and test for this behavior specifically... it may not be sufficient to just provide the ability to "save PNG with transparent background"