Keep sketchup files lightweight : desynchronise albedo slots

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • This is a rather technical request, but I think it would be very beneficial for the workflow with Enscape (this is inspired by the workflow of some of your competitors). Would it be possible to desynchronize the 'albedo' slot of Enscape textures from the 'image texture' slot in SketchUp? The advantage is to use high-resolution textures only in Enscape while keeping SketchUp lightweight. Currently, SketchUp files become very large quickly because they incorporate the same albedo files as Enscape, and the files become cumbersome to handle.

  • You can untick the "use maximum texture size" option in SketchUp to stop SketchUp trying to use the larger images.

    SketchUp will stop at 4096*4096 and downscale to this if the texture is larger.


    If the box is unticked then it will only use a 1024x1024 image.



    Enscape actually does a similar thing anyway, as discussed in a couple of threads, where 4K textures are rarely visible at that resolution - so you could perhaps use

    SketchUp's new renderer handles those things much better than it did anyway, so if you aren't on 2024, it may be worth a go.

  • Thanks Adam,

    But in this case, does Enscape still use the maximum texture size ?

    Yes, here is an 8K noise texture loaded as a texture in SketchUp at SketchUp's maximum texture size.



    Here is when I untick "load maximum texture size"



    Enscape is loading the internal file from the SketchUp material and is using it's own logic for how best to use that 8K texture - not what SketchUp is rendering in the viewport.

  • Adam.Fairclough


    But are you really sure that Enscape is using maximum texture size on your example ?

    Enscape adjusts the texture resolution based upon several parameters - such as the size of the surface to which it is applied.


    In this case, because my surface wasn't large enough to warrant it - enscape has downsampled it on it's own.

    You can see this in the enscape logs


    6-06 11:21:33.855 8f60 [INFO] Downscaled texture: C:\Users\adam.fairclough\AppData\Local\Temp\Enscape\SketchUpTextures\19916\8kbq.png_ay3m1lab.tga - cat(6) from (8000,8000) to (4096,4096)


    You can see there that Enscape has loaded the original texture at 8K and to maintain performance, scaled it to 4k. So what we've done in the modeller itself has no bearing on what Enscape chooses to do with the texture file.



    Coming back to the original query,I don't believe SketchUp 204 is so so impacted so much by having the large texture, beyond the filesize becoming larger.

    It reduces the quality of the texture quite significantly.


    Enscape will always do what it's algorithms feel is right to maintain performance, using the original file you loaded, entirely independent of what has been loaded in via SU/Revit/Rhino etc.

  • @Adam.Fairclough


    Sorry, you responded too quickly ! I had confused in your previous answer the Enscape render and the SketchUp model !

    I didn't have time to delete my question before you responded.


    No problem!

    I know it was a feature request you've made, but I thought it might be useful to know that you don't need to worry about it too much as it's kind of in hand between SketchUp and Enscape :)