Enscape trees incorrect scale when using Rhino worksessions of models with different scales

  • Enscape trees are not rendered at the correct scale when using rhino worksessions with files of different units. The proxies in the rhino viewport look correct, and all rhino geometry is rendered correctly, but the enscape trees are wrong. Running enscape from the individual files works fine, the problem is just when using worksessions.

    Steps to reproduce:

    1. Create one Rhino file, add some geometry and an enscape tree.
    2. Create a second Rhino file with different units from the first. Add some geometry

    3. Attach the first file to the second using worksessions. In the rhino viewport, everything looks as expected.

    4. Start enscape, and the tree is scaled incorrectly

  • Thanks a lot for the submission cwm , I'll try to reproduce this problem accordingly and file a corresponding bug report. I'll get back to you once I have any news regarding this subject. :)

  • It seems the problem is not just worksessions, but anytime the units of a file change after adding the enscape trees.

    Steps to reproduce:
    1. Create a new rhino file. Add some geometry and an enscape tree.
    2. Change the units of the rhino file. Select 'yes' to scale model geometry. In Rhino viewport, everything looks as expected.

    3. Start enscape, and the tree is scaled incorrectly.

  • cwm I exactly performed the mentioned steps and our assets scaled accordingly.

    Units were changed from millimeters to meters and all object got small instantly.


    Are you using Rhino 6?

    Which Enscape version are you using?

  • I checked on other computers and had the same result.

    After playing around a little more, if the units are changed while Enscape is running it initially looks correct in both Enscape and Rhino. Closing and reopening Enscape shows the problem in Enscape.

    I've attached some screenshots. I started the model in millimeters, placed two boxes and a plant. I ran enscape, and while enscape was running I changed the model units to centimeters. I then closed enscape and restarted enscape (units still in centimeters).

  • cwm , thanks a ton for your further reply and the additional screenshots. I was able to reproduce this issue (sometimes it does seem to work fine) and I'll get together with our developers to find out the cause behind this. Again, thank you for your cooperation and patience.

  • cwm , we've filed this behavior at hand as a bug report accordingly and you can be assured that we're now aware of this issue and busy resolving it as soon as possible. Thanks a lot once more for your cooperation and feedback in this manner and please let me know if there is anything else I can assist you with.

  • Demian Gutberlet , I am having this problem as well and have no idea how to fix it. Is there another solution besides waiting for 2.6?

    This problem is already resolved in our latest preview which you can acquire through the following short guide detailed here! :) Let me know in case you experience any other problems.

  • This issue is still there in 2.6 and 2.6.1 preview . The file scale in rhino was changes and the proxy tree objects do not show.


    also not this is not just for work share, a regular rhino 6 file where you change the units will cause an issue as the tree/people/entourage blocks are not properly updated , visually they scale but in enscape that are still at the old scale.

  • Hello Demian Gutberlet I am having this issue with Rhino 6 and enscape 2.7. If it is supposedly already solved since 2.6, could you guide me through the right procedure to avoid the problem?

    Welcome to our forum! :) In the first instance, please give the preview a try:

    Where can I get the Enscape preview?


    If that doesn't help, please briefly provide the steps you took to reproduce this problem, that would be great for troubleshooting purposes. Thank you! :)