v4.0/4.1 SEVEN TIMES slower than v3.4

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • We have been holding our users back on Rhino 7 + Enscape 3.4.x for over a year now. Between the 3.5.x updates, Rhino 8, and the finger pointing at McNeel, there were just too many issues. It seems that every time I see a post about a new release or preview version, it is followed by something still not working right with Rhino.

    With more users asking for Rhino 8 and the inevitability that Enscape 4.1 will be required for Revit/SketchUp updates, I just tried the latest versions with Rhino. I have a large test file (which I have sent to Enscape in the past, for troubleshooting with the 3.5.x updates) that I use as a benchmark.

    Testing was done on two different systems, 13th Gen Intel, Ada 4000/5000 GPUs, 64GB+ RAM. These are basically "fresh" systems. 3.4.2 and Rhino were new installs, Enscape was properly uninstalled, including removing everything from %appdata% between installs. Enscape default prefs, nothing custom, no settings changed. Times noted are rough averages between the two systems.

    Times to launch the model into Enscape:

    Rhino 7 + Enscape 3.4.2 - 1:15 (1 minute, 15 seconds)

    Rhino 8 + Enscape - 7:30 (7 minutes, 30 seconds)

    Rhino 8 + Enscape 4.1.0 p5 - 6:30 (6 minutes, 30 seconds)

    I have not spent time doing comparable tests on Sketchup and Revit yet, as this egregious result in itself tells me that we should just hold on 3.4 as long as possible. Can anyone from Enscape comment if this is expected behavior? As mentioned, I have sent the files in the past, it should be trivial to replicate on your end. Happy to engage in further discussion to guide you through it.

    • New
    • Official Post

    Thanks a lot for your comprehensive post rifkin , it is appreciated.

    Right away to add some current context you can check out this pinned post regarding why you may generally experience performance issues with larger projects or in this case essentially longer loading times on top compared to Enscape 3.5/3.4 or below.

    I was able to reproduce these more specific loading times you detailed with the help of your project which has been sent to us prior - At this point I can say that we are already in contact with McNeel of course to get behind these performance/loading behaviors (as per the linked post) and yours and other users projects we received will be very helpful here.

    I'll make sure to notify you right away once there'll be additional updates in this regard soon, for example when you should be able to upgrade fully without any major performance increase navigating the scenes especially if they might be on the more complex side.

    While I wish I had more positive news currently, we can assure again that this is something we are currently actively resolving with the help of McNeel. Stay tuned for said replies/notifications from my side.

  • Thanks for confirming.

    Can you comment if you have had internal discussions, if it would be at all possible to allow different versions of Enscape to be installed for different host software?

    While the Rhino 7/8 issues are disappointing, having to stay on an older version for a year is not the end of the world. The thing that makes it incredibly difficult, is that we cannot use both Revit 2024 (requiring 3.5+) and the "better performing" Rhino 7 (with 3.4.x) on the same system.

    We have seen this time and time again for years, where some bug related to one software holds us back from updating all of them. Revit, Rhino, and Sketchup are all used extensively by many of our users. If we were able to choose the "best" version of Enscape for each host that would go a long way toward mitigating our frustrations.

    • New
    • Official Post

    rifkin , this is something which is unfortunately still not possible currently and may not be anytime soon I'm afraid.

    There might be a dedicated workaround for this specific situation here (I wish I could make any definite promises yet), I am still currently troubleshooting a few solutions so please kindly check your direct messages here in this forum soon a bit later today - As of yet I wouldn't want to share this openly, but expect to hear from me again very soon.

    EDIT: You can now check your direct messages again for that further response/potential workaround.