Going to have to revert from 2.5

  • Hey Enscape team, its sad but I'm going to have to revert to an earlier version of Enscape. This 2.5 update is causing all kinds of material problems and is just super buggy. Materials randomly go black iin large scenes. It suddenly just freezes up. Its taking for ever to launch the scene. Its just a little too buggy for this go.

  • What materials problems are you seeing? I have a large complex scene, and usually one or two maps are switched out with a map from one of the proxies that's loaded. For example a hand towel pattern is replaced by a carpet pattern from a different part of the model that's loaded as a proxy. This had been an issue for me in the 2.4 versions too (I just keep forgetting to post a bug report about it.) (btw, I'm running SU2017pro on Windows)

  • In my case.. 2.5 for sketchup works .. just a little bug.

    The texture position and scale not showing as it is on the sketchup model. I need to explode the the model ( then the texture are now sync correctly )
    I noticed that when i explode the model, sketchup now shows the texture actually in the position as it in enscape. I mean.. that enscape actually show the real position of the texture that you need to correct it in your model.

    Skethup 2018
    Win 7 pro.

  • Hi Ted.Vitale

    what you observe may be the result of 8k textures support introduced a couple of months ago. Please send us a feedback so we could have a look at the logs to figure out if it is the case.


    andybot would be nice to have the scene to test. Please contact support via feedback or me via PM.


    Prime this is also interesting, please send us an example scene if it is possible

  • Prime Is, by any chance, the surface itself without a material and the texture is applied at the component/group level?

    This has never been supported, SketchUp does not give us the correct UVs in this case.

    Yeah.. this what i mean.. I dont think it is a problem from enscape. Ive seen this quite long even in a computer without Enscape installed ( exploding model wll make the texture seem to move or 'reset' ) Maybe the texture applied on a group.


    So far, i got no problem working with Enscape, just some of my textures on model need to re-adjust a bit. thats all and Im good to go

    walking on the moon.

  • Hey Enscape team, its sad but I'm going to have to revert to an earlier version of Enscape. This 2.5 update is causing all kinds of material problems and is just super buggy. Materials randomly go black iin large scenes. It suddenly just freezes up. Its taking for ever to launch the scene. Its just a little too buggy for this go.

    Hello there!

    I hope everyone in this post are ok,

    I am having exactly the same issue my scene is basically huge! i manage to reduced from 2GB to 200mb, improving overall quality, betwen textures, models, assets, proxies, etc,


    the funny part is that exact same model in the version 2.4.2 10-g5495b9a works perfectly fine for me, but any recent version of Enscape shows exactly the same error making a bunch of the textures black and almos imposible to work with the model in Enscape Realtime I am attaching 2 Images same scenes with different versions of Enscape,


    Enscape Ver. 2.4.2 10-g5495b9a (Render took 5 seconds)



    Enscape Ver. 2.5.0.50-gd44f62a (Render took 2 Minutes)



    Also keeps showing me that my Graphic card drivers are outdated which is not true, may be a bug?



    I got

    Intel Xeon W-2125 @ 4.00GHz

    32GB of ram DDR4

    GTX 1080 Ti

    SSD


    So, I don't think is a lack of hardware :)


    I will revert back to the version that works just fine so far until there is a solution for this problem,


    Also I should mention that the texture in black is an 8k+ texture to be more accurate is a 7715x5154 pixels texture,

    could be that affecting the performance?

    And also is it possible to know what is the maximum texture size supported by enscape then?


    Thank you in advance for any feedback or support!

  • Hi! Thank you for the feedback.

    Also I should mention that the texture in black is an 8k+ texture to be more accurate is a 7715x5154 pixels texture,

    One 8k texture should not be a problem. It may come to problems when you have more texture data than can fit into GPU RAM. Keep in mind that you may use the 8k texture not only as diffuse map, but also as a bump map, maybe roughness map, etc. Alltogether takes much more space than one 8k texture. When you have multiple big textures, RAM can run out pretty fast. It would be nice to have the complete scene to have an example of broken behavior.

    And also is it possible to know what is the maximum texture size supported by enscape then?

    8192x8192px is the texture size limit in 2.5. 2.4 had the limit of 2048x0248px.


    Please contact us via feedback function or via PM here on forum.

  • Hi! Thank you for the feedback.

    One 8k texture should not be a problem. It may come to problems when you have more texture data than can fit into GPU RAM. Keep in mind that you may use the 8k texture not only as diffuse map, but also as a bump map, maybe roughness map, etc. Alltogether takes much more space than one 8k texture. When you have multiple big textures, RAM can run out pretty fast. It would be nice to have the complete scene to have an example of broken behavior.

    8192x8192px is the texture size limit in 2.5. 2.4 had the limit of 2048x0248px.


    Please contact us via feedback function or via PM here on forum.

    Got a question. How the bump and other additional cards work.

    For example. There is a diffuse map of 1000 by 1000 pixels. How will a relief map of 100 by 100 pixels lie?

  • I think Julio has the best example. Ill see if I can reproduce the same issue. Right now I'm using 2-4k textures in a medium sized scene and running into the black out texture issue shown above. Alexander Devaykin , I'm running a GTX 1080ti and if its a card RAM issue why would it occur in 2.5 and not 2.4, because of the new texture size limit being increased? I feel like the cap to resolution should be related to the available ram not a generalized limit.

  • Sending feedback from the scene now :)


    Doesn't seem to want to send. Is there direct email that might be better to send the file?

  • Is there direct email that might be better to send the file?

    Sure, I'll contact you via PM and give you the address.

    I'm running a GTX 1080ti and if its a card RAM issue why would it occur in 2.5 and not 2.4, because of the new texture size limit being increased? I feel like the cap to resolution should be related to the available ram not a generalized limit.

    Before 2.5 all textures were scaled to max 2048x2048px. If you've used 4k textures all the time - they were scaled down to 2048x2048, thus taking two times less RAM. I hope your model will give us an answer if it's RAM issue or something else.

  • Sure, I'll contact you via PM and give you the address.

    Before 2.5 all textures were scaled to max 2048x2048px. If you've used 4k textures all the time - they were scaled down to 2048x2048, thus taking two times less RAM. I hope your model will give us an answer if it's RAM issue or something else.

    It sounds like its a ram issue and at some point I'm just running out. Ill send along the model today.