enscape error:'This action cannot be completed because the other program is busy. Choose 'Switch to' to activate the busy program and correct the problem"

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
    • Official Post

    Hey eden , in the first instance, would you please be so very kind as to make sure that your windows is up to date, as in, install any updates which are currently available? If you've already done that, could you just try to run the main CAD solution you're using Enscape with, and Enscape itself of course? Does that help?


    If not, please send in a feedback report if possible as described here, and add your forum name in the submission form so we can connect the report to this thread.

  • @edem Trying not to get to technical, but that dialog is shown when Enscape is busy. Normally you should not see this window, but when you switch the focus back to the main window of your CAD, Windows will notice that an action (a COM call to be specific) did not complete yet and show the window. It's similar to the "XYZ is not responding" dialog and you should handle it the same way; you just need to to wait. Switch to will just make the window go away, but if the action is still running, it will reappear. You should be able to just leave the dialog standing and it should disappear once the action is completed.


    But since generally this dialog should not appear, can you please tell us what you did when the dialog appears, so we can ensure that this specific instance does not appear.

  • But since generally this dialog should not appear, can you please tell us what you did when the dialog appears, so we can ensure that this specific instance does not appear.

    I normally click the "manage upload" dialogue just before I click to generate a panorama: the error message appears every time and I have to click "retry" every few mins until I see more than one drop-down with hundreds of blank 'sun' holder icons. (just timed it: about 13 min). It does not vanish and the thumbnails do not load, but the drop-downs do eventually split into the sorting order and each one can be 'viewed' and 'do more'


    I have ~330 panoramas.