SketchUp, Layer visibility (by scene) ignored in flythrough video

  • Actually thought this is a missing feature, but on one of recent webinars Kaj confirmed that this should be a bug. So - here is my report.


    Trimble SketchUp Pro 2019 (19.1.174)

    Enscape 2.5.3.0


    I've attached a simplified model to visualise the issue.


    1. Setting up scenes in SU with different visible layers (to demonstrate development of the model)

    2. Adding these scenes as keyframes for the video in Enscape

    In resulting video, layers are visible as per first (active) scene. No changes in their visibility during the video.


    Just to confirm - is this a bug or a missing feature?

  • Hey Dmitry , thanks a lot for your post and welcome to our forum. :)


    It is currently not yet possible to include layer transitions in our videos through the video editor. Sorry about the confusion! This has definitely been requested before and we're aware of the demand of an implementation to allow this - thus I've also gladly forwarded your feedback to our developers to state the additional demand from you!


    If anything is unclear or in case you have any other questions, feel free to let me know.

  • Thanks, Demian Gutberlet, I thought that this may be the case.


    I understand. Will wait patiently :) As scene transitions and support of basic animation plug-ins like Animator are a key to bring some dynamics and "life" to otherwise great looking Enscape videos. (plus it seems that adding scene transition will not require a major re-work, as it is basically a question of stopping the rendering and refreshing visibility of layers as per SU Scene linked to a keyframe, possibly with an option to add some basic transition effects to a step from one state to another, and continuing rendering with a an updated state of layers. Obviously, adding support of Animator will be more difficult)

  • Dmitry , we also have a further feature request on our agenda (quiet demanded already) to generally support animations in Enscape. I've also added your upvote to that topic too! Thanks for the feedback. :)