3D Connexion Space Mouse

  • timeless , thanks a lot for report. We're aware of this behavior already. This is actually filed as a bug report on our agenda, although we were not able to reproduce this behavior at all yet.


    Thus, it would be helpful if you could answer the following:

    - Does this occur when using our latest release?

    - Which version of SketchUp are you using Enscape with?

    - Was this working before as intended, and if so, what was different? Maybe you used an older version of Enscape for example?


    Afterward I'll forward your feedback to our developers. Thank you in advance. :)

  • See answers below "[Kris]..."

  • I've actually found that it hasn't worked with SU for a long time (but works with Enscape); I was surprised when it actually worked with SU in the previous preview release (although the SU was inverse to the En directions) - currently I am finding it only working in Enscape.

  • I've actually found that it hasn't worked with SU for a long time (but works with Enscape); I was surprised when it actually worked with SU in the previous preview release (although the SU was inverse to the En directions) - currently I am finding it only working in Enscape.


    Try using your spacemouse before you fire up enscape. If it does, problem solved. If it doesn't > go to extension manager and make sure that the extension is 'enabled'


    Hope this helps

    Cheers!

  • Personally I only use the spacemouse in Enscape, and only use the mouse in SU so it's not a problem. (The calibration to get identical movement between the two is almost impossible, so it's not worth spending time to get them to work properly together.)

  • Personally I only use the spacemouse in Enscape, and only use the mouse in SU so it's not a problem. (The calibration to get identical movement between the two is almost impossible, so it's not worth spending time to get them to work properly together.)

    Well I draft & design in SU - Enscape is an visual aid. So If I may choose it need to work a/ SU b/ Enscape

  • I use my spacpilot in my SU workflow a lot, when running ensape the focus switches to the render window, have to close enscape to get the focus back to sketchup. Been using a spacepilot for about 7 years now, in Sketchup, max and C4D, Great tools :-)

  • Up until the last release I was always able to use mine in both skp and enscape depending on which window I click into. Since the last release I can only use it in Enscape unless I close Enscape and then I get functionality back in Skp. Both are the lastest versions.

  • From version 3dconnexion drivers 10-6 upwards I have the problem that by activating Enscape my Space Pilot pro no longer works in SketchUp but in Enscape yes. I have to close the file and reopen it. SU pro 2019.2, Enscape 2.6.1.

    I currently resolve using the old drivers 10-5-15.

  • 3DxWare64_v10-5-11_r2875 is the driver that works for me. Anything after that I can't use skp and enscape at the same time. Enscape works but skp does not. Then I have to back enscape up to 2.5.3 in order to get the 3d mouse to work as expected (anything after that reverses orbits and does not seem to pan or go up and down)


    I hope this gets addressed asap as it is critical to my workflow however its seems to me both Enscape and 3d connexion have things causing this.


    I also spoke with 3d connexion and they said they do not support / test with enscape.

  • So I spoke too soon. I have tried every combination I can of old and new drivers and now I can not get the 3d mouse to work in Skp. See image. When I am in Skp even without starting enscape it says I am using enscape. Even if I disable it in the Extension manager. Short of uninstalling Enscape I am not sure how to get it working again in skp. Way too much time wasted just trying to make tools work that were working fine until things were "upgraded." Windows is I think partly to blame as well as it breaks my computer every time it forces an update.

  • Windows is certainly partly responsible (a few days ago if I activate WhatsApp web with open SketchUp I turn off the 3dconnexion drivers and I have to restart the PC, if instead whatsapp is already active everything works), however uninstall the 3dx ware completely, restart and install again the drivers that work for you. I think it's the fault of the 3dx ware drivers from version 10-6 onwards.

  • So I tried 10.5.15. It works perfectly with Enscape 2,5 So I tried 2.6 and while it now works in both SU and enscape it flips and kills many of the 3d mouse controls. Rotate is backwards up and down does not work orbit is backwards. Forward and back seems correct (note the controls work correctly in Skp). Using 3d Connexion 10.5.15 and Enscape 2.5 is the only combo I can find that works both in SU and ENscape and the controls work as expected in Enscape.

  • Thank you! Simon Weinberger That must be a default. I never changed / noticed it before but in the old version it seems to be set to "invert space mouse" by default (ie I had just reinstalled the old version and it was already set to "invert".) So then I tried reinstalling the new and it was NOT automatically checked. Just checked the box and that Solved that problem thank you. 2.6 also seems to be switching fine between skp and enscape with the old 3d conn drivers.


    dvsone1440 Because we changed how settings work it was impossible for us to convert all settings to the new format. You might have changed "Invert SpaceMouse" in 2.5 and now it's back to default. Open "General Settings" and look under the "Input" section.