3D Connexion Space Mouse

  • Have just updated to Enscape 3.1 public release and have noticed as soon as enscape is open my space mouse stops working in Archicad 24 however close enscape and starts working again straight away.

    Welcome to our Forum! We're still in the process of looking into it, a developer is on working on resolving this behaviour again.

  • There's also a intermittent bug where it stops working in SketchUp but still works in Enscape. Relaunching SketchUp fixes it. Can't confirm if this is a Windows, SketchUp, Enscape or 3DConnection driver bug. Hard to tell. Inclined to assume it is a driver fault in windows.

  • It killed my skp with Enscape open. There is a new 10.7.4 driver for 3d connexion I am going to try. I wish this wasn't quite as painful every time I update enscape but I guess it is a lot of variables between nvidia / skp / enscape / 3dconnexion

  • Unfortunately, after a few months, the problems with our 3Dconnexion peripherals return. The problem starts with preview 3.1.10, until 9 everything worked fine. The 10.7.4 drivers do not solve the problem. If you use 2 monitors like me the current solution is to activate the sync between SketchUp and Enscape and navigate in SketchUp. Several times, however, you have to (or out of habit) to move to the Enscape window and the block in SketchUp occurs. I solved it by putting the 2 icons "stop 3dxware" and "start 3dxware" in the taskbar to be able to navigate again in SketchUp. When it freezes you go back to SketchUp, click on 3dxware stop and after about 10 seconds click on 3dxware start and it starts working again. This disturbs enough but in the meantime it works, we hope for a quick solution. This is my experience with 3Dconn Enterprise, 10.7.4 drivers, nvidia 471.41 studio drivers optimized for Enscape 3.1, SketchUp pro 2021.1.1.

  • Updated to the latest 10.7.4 drivers and the issue persists. Looks like it lost "focus" when I minimized SketchUp to work in some other programs. Opening the Spacemouse connection properties shows that is is "sticking" to Enscape 3D and won't go to SketchUp. But it does switch to other open apps, like firefox, adobe, etc when I click around to each of those. I keeps thinking SketchUp is Enscape.

  • Unfortunately, after a few months, the problems with our 3Dconnexion peripherals return. The problem starts with preview 3.1.10, until 9 everything worked fine. The 10.7.4 drivers do not solve the problem. If you use 2 monitors like me the current solution is to activate the sync between SketchUp and Enscape and navigate in SketchUp. Several times, however, you have to (or out of habit) to move to the Enscape window and the block in SketchUp occurs. I solved it by putting the 2 icons "stop 3dxware" and "start 3dxware" in the taskbar to be able to navigate again in SketchUp. When it freezes you go back to SketchUp, click on 3dxware stop and after about 10 seconds click on 3dxware start and it starts working again. This disturbs enough but in the meantime it works, we hope for a quick solution. This is my experience with 3Dconn Enterprise, 10.7.4 drivers, nvidia 471.41 studio drivers optimized for Enscape 3.1, SketchUp pro 2021.1.1.

    can you elaborate on how you make the taskbar icons?

  • Unfortunately, after a few months, the problems with our 3Dconnexion peripherals return. The problem starts with preview 3.1.10, until 9 everything worked fine. The 10.7.4 drivers do not solve the problem. If you use 2 monitors like me the current solution is to activate the sync between SketchUp and Enscape and navigate in SketchUp. Several times, however, you have to (or out of habit) to move to the Enscape window and the block in SketchUp occurs. I solved it by putting the 2 icons "stop 3dxware" and "start 3dxware" in the taskbar to be able to navigate again in SketchUp. When it freezes you go back to SketchUp, click on 3dxware stop and after about 10 seconds click on 3dxware start and it starts working again. This disturbs enough but in the meantime it works, we hope for a quick solution. This is my experience with 3Dconn Enterprise, 10.7.4 drivers, nvidia 471.41 studio drivers optimized for Enscape 3.1, SketchUp pro 2021.1.1.

    UP !!!!

  • We have just released a new 3.1 version which should address the issue where Space Mouse is not working in SketchUp after its been used in Enscape until Enscape is closed.


    Please use this download link and let us know in case this did not resolve it for you.

  • Still doesn't work after updating to 3.1.51825.

    Enscape isn't even open, but 3d connexion property shows Ensacpe instead of Sketchup.


    Hopefully it'd work after restarting the computer.


  • Still not working.


    I reinstalled the latest 3d connexion driver and rebooted the computer. But it's not working. The property button on the 3d connextion mouse bring up Enscape property instead of Sketchup even though Enscape isn't even open.


  • Showing Enscape even if only SketchUp is open is normal, then that it doesn't work I don't know. But it just doesn't work in Enscape or even in SketchUp, or it crashes when you open Enscape and then it doesn't go to SketchUp anymore ??

  • The 3d mouse works in Enscape window, just not working with Sketchup. It doesn't register at all.

    I remember the 3d connexion property showed Sketchup when Sketchup window is active (when it was working before. )