3D Connexion Space Mouse

  • Any movement on getting this fixed?

    I tried to ask for help here: https://www.3dconnexion.com/fo…d4ee26f3fa16169852b0861e5 and also to 3dconnexion Italy assistance but the answer was that Enscape is an unimportant software and therefore not supported. This is sad and makes me think that it would be right that the Enscape team and the 3Dconnexion developers should communicate to solve the problem ... the will to do it is enough.

    This is the answer from a forum developer:

    Hi 4interiors,
    We have a problem with Enscape and Sketchup.
    I'll try to come up for something relatively easy. Easier than reinstalling software anyway.
    Sorry for the troubles. Enscape is a pretty non-existent app in our installed base so it's hard to get time to work on it.

    This is the response of 3dconnexion Italy assistance:

    Thank you for contacting 3D Connexion support.
    Enscape 3D is unfortunately not an application supported by our mice.
    I invite you to contact Enscape 3D technical support for assistance.

    Regards



    At this point the Enscape team should act !!!

  • fyi I was able to hack this to make it work based on some earlier threads. Using 10.5.15


    I agree completely that Enscape should work with 3d Connexion to fix this however. If you use a 3d mouse with Enscape you will never go back. However it is more than frustrating that this cant get fixed for the latest drivers.

  • fyi I was able to hack this to make it work based on some earlier threads. Using 10.5.15


    I agree completely that Enscape should work with 3d Connexion to fix this however. If you use a 3d mouse with Enscape you will never go back. However it is more than frustrating that this cant get fixed for the latest drivers.

    True... this is very frustrating! If you want to stay relevant you want to use the latest gear/ correctly adjusted drivers

  • New drivers 10.6.9 available, on the 3dconnexion forum no answer regarding our problem, someone who wants to try them?

    Our developers received further reports of this particular issue, we're looking into any solutions to resolve this - in the meantime, the advice is to actually update to the latest drivers available, could you perhaps try that and get back to me? :)

  • Our developers received further reports of this particular issue, we're looking into any solutions to resolve this - in the meantime, the advice is to actually update to the latest drivers available, could you perhaps try that and get back to me? :)

    Unfortunately, since version 10.6.6 they have changed the installer and this is invasive in the operating system. Before (up to version 10.6.5) it was enough to uninstall the drivers and go back to the old and trusted 10.5.15, now you have to delete everything related to 3dconnexion even by acting on the windows registry otherwise it won't work even by putting the old drivers. I am sorry not to collaborate but I have recently formatted to have a clean system, I have always tried to help those who needed by explaining the currently working solution several times, I hoped that someone wanted to try them. Allow me to say that I should not try them, nor another Enscape customer but you should do it, you should have already done it since the driver solution 10.5.15 you have not found you Enscape team and that these drivers are from April 2019, they do not support SketchUp 2020 and a tutorial has not been written by you on how to temporarily solve the problem. I understand that there are many things to do and that Enscape is in continuous development and I appreciate it, but I think the problem can be solved, you just have to work hard to keep the customers who use these devices happy even by contacting the 3dconnexion developers.

  • I am like 4interiors I don't want to spend more time trying to get my computer working again as I have already spent lots of hours on this and have it working with the old driver. That said I do have another computer now that I can experiment on. I will try this but would also reiterate what 4 interiors said that it seems like this is something that Enscape should tackle asap. I am not sure why this is such a low priority as I find using this 3d mouse with Enscape makes the experience infinitely better.

  • I understand that 4interiors and dvsone1440 . This is something I will definitely have to re-discuss with our developers as I can also understand that a dedicated Space mouse will just provide a great experience for some in terms of workflow and such. :) I'm sorry that there are currently problems regarding this combination, but as mentioned, I'll discuss it internally as soon as possible.

  • Add Revit to the equation. I posted in the Revit forum and was guided to this thread. My issue is slightly different, as whether I have Enscape open or not, my spacemouse will drop out randomly in Revit, anywhere from a few minutes to an hour into a session, usually when I'm on my second monitor on the web or in another program. Having Enscape open and switching between wasn't making it drop out, it was totally random and would even drop out if I just left the computer sitting for 10 minutes or so, which is why I hadn't considered it was an issue between Enscape and 3Dconnexion. When it drops out in Revit it also drops out in Enscape but then if I close Enscape and re open it the spacemouse will work in Enscape but not in Revit which is how I've been using it. If I close down Revit and then re open it will work in both Revit and Enscape for an unpredictable length of time until it drops out, which it always does.

    I've been through a lengthy period with 3Dconnexion trying to find a solution with no luck and hadn't even thought that it could be the interaction with Enscape that was causing the problem, but here I am 6 hours into a Revit work session after uninstalling Enscape completely from my computer, and Revit and my two 3Dconnexion devices are working flawlessly.