recurring crashes when Photoshop CC is in GPU accelerated mode.

  • I've been having recurring issues with Photoshop being in GPU mode and Enscape crashing without an error report popping up. Anyone else experiencing this?


    I try to remember to keep Photoshop in GPU off mode, but when I forget and have Enscape open the chances are high that Enscape will crash. Also, today I noticed that when I started Enscape, it was very sluggish when I had a very large (+2GB) PSB document open, I was working in Sketchup on a model with approx 662K faces, and 200+ Enscape people. My PC setup is a main 4K monitor + HD monitor on one GPU (2080 ti) with 64GB RAM, Ryzen Threadripper 2950x. Enscape version is most recent 2.5 version.


    And my Nvidia driver is up-to-date and is the Game-ready option. (The Creator-Ready one did not work for me.)

  • giri-giri , thanks a lot for your report. :)


    In this case, to further troubleshoot the cause behind these behaviors, could you please kindly send in a dedicated feedback report as described here? Please also include some reference like your forum name so that we know it's coming from you. Additionally, if you haven't already, please also update to Enscape 2.5.3 as shown here.


    Also, regarding the performance issues you're experiencing, have you perchance adjusted the Rendering Quality, to, Ultra for example? Anything else you could think of which you've done before the performance dropped?


    Thank you in advance!

  • Hi Demian,


    The rendering quality is always set to 'high', never 'ultra'. I had just started Enscape and Photoshop was already running for awhile (maybe an hour). My Enscape is 2.5.3. I will try to submit a dedicated feedback report.


    Thank you

  • I submitted the dedicated feedback report, as you instructed. :)

    Perfect, thank you very much. :)


    So generally, it seems that this is caused by a bug from Enscape's side. We're now investigating why Enscape is crashing on your machine under these circumstances. Thank you for a bit more patience - we'll get back to you once there'll be any news.

  • Any news on this? I keep having crashes when Photoshop or Illustrator are running and in GPU mode. There's some conflict with Enscape utilizing the GPU while those apps are running. Would getting another GPU help? I have a single 2080ti.

  • Any news on this? I keep having crashes when Photoshop or Illustrator are running and in GPU mode. There's some conflict with Enscape utilizing the GPU while those apps are running. Would getting another GPU help? I have a single 2080ti.

    It's still filed as a bug report on our agenda, but there is no solution yet. At this point, I'm afraid, I'm yet unable to tell you if getting another GPU would help. I'll forward this to our developers once more to see if they can find out more!