Oculus vs Vive controls when teleporting - asking to get Enscape working with the Quest

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • As explained in the other thread I have Enscape working wirelessly with the Oculus Quest. This make roomscale demonstration on client locations so much easier. One backpack with my laptop and my Quest. No basestations, no wires, no extension cords, no stands for the basestations, no PC with the wireless card for my Vive.

    One issue to resolve.

    The trigger button on the Quest controller will show the teleport arc but I cannot click and do the actual teleport. This is how the Vive controller works. Pulling the trigger will show the arc. Clicking the trigger will do the actual teleport. This last click seems to be missing with the Quest controller. In SteamVR you can do a controller test which confirms registering the pull action but not the click action.

    Tonight I chatted with the creator of Virtual Desktop and he tested the Quest and Rift and reported back that both show the same behavior in the SteamVR controller test. In other words both don’t show the click Enscape is waiting for.

    Can someone with a Rift explain how the teleport works in Enscape?

    @Enscape. Do you use OpenVR?

    I tried rebinding the controller keys in SteamVR which seems possible but then I cannot save the new bindings like for other apps.

    Any help would be appreciated. The solution is so close. Just one click away.

  • Hello annevanzwol

    for the Vive and all Mixed Reality devices we are using OpenVR to interface with them. The teleport is executed when either the trigger button is pressed or the trigger pull is fully done. To be specific, you can pass that to the developer of Virtual Desktop, the button that is monitored is OPENVR_BUTTON_TRIGGER, the axis for the trigger OPENVR_AXIS_TRIGGER needs to be above 0.999 and the controller needs to have the role TrackedControllerRole_RightHand.

    I hope that information helps. Supporting the Quest, even if not officially, sounds really useful.

  • Sean Farrell

    The VD developer has looked into the Quest controller issue (not being able to do the teleport) taking into account your remarks and made some changes and uploaded a beta version for me to test. Unfortunately the issue is not solved. This is the feedback he gave:

    The developer of Enspace will need to properly support this as I’ve done all I can from my end. If they need a key to test it, have them email me: guy@vrdesktop.net

    I asked for any pointers for what to look at:

    It’s hard to say, the developer needs to run it from Virtual Desktop with a Quest to see where the input is not behaving as expected.

    Maybe it has something to do with SteamVR recognizing the Quest controller as an Oculus Touch controller which seems to have a physical click on the trigger button. This is not the case for the Quest controller.

    It is so frustrating to have the perfect solution and yet be litterally one click away. The Oculus Quest setup provides fast deployment and large play areas because of the inside out tracking (no need for base stations and cabling) and a wireless experience for the user. This solution would really benefit my business and most likely that of other Enscape users.

    Please can you look into it? Maybe a workaround with another button (A or B) to execute the teleport. Or moving forward and letting go the thumbstick like it works in SteamVR Home.

  • I will look into it, but aren't the quest controllers the same as the Rift S controllers? Why not "emulate" that. Also I just checked the Rift and Rift S controllers are basically the same and behave the same. (Sans the touchy area we don't use anyway.)

  • Sean Farrell

    The way the controller is emulated is puzzling to me.

    In the SteamVR 'waiting room' I see the Rift S controller. The grip button and the thumbstick are animated analog. Pressing the button halfway will also show it halfway in VR. The trigger button on the other hand is either pressed or not pressed.

    Also in the Enscape executable I see the Rift S controllers. The buttons are not animated by the way. But when opening the key binding menu from the settings it shows the Touch controller and there is no option to choose the Rift S. Choosing another controller will not change the controller in Enscape anyway.

    As you can see the teleport arc works as expected. But I cannot execute the teleport.

    If there is any testing I can do from my end. Please let me know. I am very motivated to get this working. My system, drivers and SteamVR are all up to date.

  • Sean Farrell

    Can you give any indication if the controller issue is solvable? I am eager to deploy this solution for my business and would appreciate any feedback.

    Alternatively for the time being can you make it so that I can press a button on my laptop to activate the teleport? It is not ideal but at least workable.

    With that I mean. The user points to a location with the teleport arc and I trigger the teleport.

  • annevanzwol Tentatively yes. Using Virtual Desktop will always remain a hacky solution and I really can't give you any hard guarantees, it will remain not officially supported. I ran the Oculus Rift S through the OpenVR code path and had some minor issues, such as the analog sticks not mapping cleanly.

    But upon review, we decided to relax the endpoint threshold on the teleport trigger, this should help with the Virtual Desktop setup.

  • The relaxed triggers are going to be in the 2.7. So you should be able to test it in the first 2.7 preview which should come out in the next couple of weeks. (Currently previews are for 2.6.1)

  • icarumba If you want Quest support, you should petition Oculus. The issue is less of a technical issue, but more of a legal and policy issue. There is not reason why the Oculus software can't soft tether with a PC, the Virtual Desktop implementation shows that it works.

    But so far, Oculus does not want the Quest to work with PC applications. For this to work you need to sideload Virtual Desktop, because the version in the Oculus app store can not forward VR, because Oculus forbids it through their terms of service. And using the sideloaded Virtual Desktop app is technically a terms of service violation and voids your warranty.

  • maybe not ideal but the VD option works great and wireless VR is great

    with the new link option on the Quest wired VR becomes available this month. This allows you to use Steamvr and PC legally

    the issue is the teleport trigger not working. Hopefully it will be solved in 2.7 as stated above

    any ETA on the preview version?