Enscape-2.6.1 Not Launching

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Enscape freezes my computer at 10% Revit model export. My cursor freezes and my computer freezes. CTRL+ALT+DELETE is not even functional. I have an RTX Quaddro 5000 and was very excited for the added support. Anyone else having this issue? I have a BOXX Apexx 7-series, 32 gigs RAM, RTX Quaddro 5000, Core i7-9700K.

  • Yes. Like an idiot I updated to 2.6 yesterday evening and now I cannot run Enscape. Gets to around the same percentage when loading and crashes Revit. F$#%ing ridiculous. I guess I am waiting for support to get back to us in 2-3 business days. I dislike purchasing software from European countries due to the time difference. Out of Country Support sucks.

    • Official Post

    Enscape freezes my computer at 10% Revit model export. My cursor freezes and my computer freezes. CTRL+ALT+DELETE is not even functional. I have an RTX Quaddro 5000 and was very excited for the added support. Anyone else having this issue? I have a BOXX Apexx 7-series, 32 gigs RAM, RTX Quaddro 5000, Core i7-9700K.

    Hi cbonfield


    sorry to hear about that! Did you send us feedback with log files yet? There's a button on the Enscape ribbon for that. Since you're using a RTX graphics card please make sure to run the latest available drivers from Nvidia.


    winterriver1971

    You can download previous versions from our downloads page (there's a link below that lists all previous releases of Enscape), so can roll-back to a release that worked for you easily. Please also make sure to send log files for us in order to troubleshoot your issue.


    Thanks!