Version 2.6.1 - Start Enscape freeze

  • Small bug I've picked up with latest version 2.6.1 - if you close down Enscape and then open it up fairly swiftly afterwards (sometimes I have to do this as the live updates feature occasionally stops updating Enscape as the model is updated), Enscape appears to hang with a 'Server Busy' screen offering the choice of Switch to or Retry. Sometimes it can sit like this for multiple minutes until clicking retry lets the assets etc load and Enscape starts as normal.


    Thanks

  • I noticed this too, I think.

    First I just tested with simple box that I edited in SU while Enscape window was open.
    The box didn't update and was visible even after I deleted it in SketchUp.

    Then when I closed Enscape and started it again with just a box in SketchUp it "froze" while loading forever.

    It worked again after restarting SketchUp.

  • Sorry to hear about this - Since I cannot reproduce this myself at the moment, is there any chance you could kindly send in a feedback report with your log files? Have you also made sure that your windows is up to date? :)

  • THE 10% ISSUE


    I am experiencing the same symptoms, after getting the latest release, Version: 2.6.1+13260 | Revit 2019.2


    All has been working brilliantly with all of the previous releases, up to Version: 2.6.1+13260. Unfortunately, with the latest release every time I start Enscape, or even change something with live link on pause, then resume - whole PC freezes for some 3-5 minutes (when starting for the first time, loading stops on 10% - an issue discussed in various threads on this forum). After that time, all loads and works properly.


    - Have the latest graphics drivers, NOT THE ISSUE

    - Deleted the textures folder to see if the problem is there, NOT THE ISSUE

    - Unlinked all other Revit files from the master file to see if they don't contain any bugs, NOT THE ISSUE


    The weird thing is - I downgraded to the previous version, Version: 2.6.0+11215, where everything was working smoothly, and that has the same issue now. The model itself has not changed. The confusing aspect of this issue is that with the installation of the newest release, whatever is causing the freeze seems to have baked itself into the model, and is transcending into other older versions too (that worked perfectly prior to version 2.6.1+13260).

  • Edgars Janeluns , sorry to hear about that - please also send in a report as described in my last reply above. That would be extremely helpful! We'll receive log files generated by your machine which should tell us why you experience this issue.

  • Sorry for a double post, but maybe this helps the Enscape Team to narrow down the issue search.

    This is what happens during a typical working worksession in Revit:

    a) pause Live Updates

    b) make changes

    c) Resume Live Updates (after this typically there is a status bar on lower left corner within Revit, showing that the changes are loading into Enscape)

    d) Pop-up status bar saying 'Exporting to Enscape'

    d) Lower bottom left corner of Enscape window shows a circulating loader animation, indicating the update of Enscape view.


    This is what happens during the latest release worksession in Revit:

    a) pause Live Updates

    b) make changes

    c) Resume Live Updates (after this typically there is a status bar on lower left corner, showing that the changes are loading into Enscape)

    the speed of this status bar has not changed in comparison to the previous versions, it works flawlessly without any delay.

    c+) Revit freezes, Pop-up status bar as black solid for 3-5 minutes (see attached image)

    c++) Revit unfreezes, Pop-up status bar comes back to life and runs all the way to 100%

    d) Lower bottom left corner of Enscape window shows a circulating loader animation, indicating the update of Enscape view.


    The freeze begins right after Revit has packed all info to be sent to Enscape, and the Pop-up of Enscape export comes up.


  • Edgars Janeluns , sorry to hear about that - please also send in a report as described in my last reply above. That would be extremely helpful! We'll receive log files generated by your machine which should tell us why you experience this issue.

    already done! sharing my experience, so maybe others can relate with similar issues..

  • Hi, just a small update on this one - I haven't had the errors again that I noted in my OP but what I'm finding now is that if I close down Enscape (when say the live refresh stops working), if I open it up again within about 5 minutes, Enscape loads to 2% then stops. Sometimes it takes 30 seconds to continue loading, sometimes a couple of minutes. It always seems to kick back into life though!


    Not a major issue

  • Hi, just a small update on this one - I haven't had the errors again that I noted in my OP but what I'm finding now is that if I close down Enscape (when say the live refresh stops working), if I open it up again within about 5 minutes, Enscape loads to 2% then stops. Sometimes it takes 30 seconds to continue loading, sometimes a couple of minutes. It always seems to kick back into life though!


    Not a major issue

    Sorry to hear about that!


    In this case, still, it would be nice if we could also require a feedback report as well to troubleshoot the cause behind this problem. Would you be so very kind?


    Thanks a lot in advance! :)

  • Hi, Feeback submitted! What I've done:


    Created a super simple scene (floor, wall, one self illuminating material)

    Started Enscape with no issues

    Shut Enscape down, then started it again about 10 seconds later.

    Enscape loads to 2% (Preparing Resources) then stops and I get the 'Server Busy, Switch/Retry' Dialogue. This persists for about 2 minutes until clicking 'Retry' Enscape carries on beyond 2% and loads fine.


    As I say, not a big issue and maybe its user error starting Enscape so swiftly after closing it, but thanks for looking at it!

  • Thanks Peter!


    For the benefit of anyone else with the same issue, its normal behaviour - to speed up closing the Enscape window certain resources are cleaned up later (physics data for example), so if you immediately restart Enscape after closing it, then it pauses to process longer than usual as it hasn't finished clearing the data from the previous session.