IES files incorrect behavior for grazing / wall washing outdoor application

  • Hi,


    I've inserted in my Revit model some custom families of "architectural" lighting fixtures (by a lighting fixtures manufacturer).

    This lighting fixture is intended to be installed inground and to be used for illuminating vertical surfaces and facades with a grazing/wall-washing effect.


    Just to give you an example of the fixture possible effect, see the following rendered view:




    Enscape v2.6 renders the light emitted by the ies files for this specific use in a very unproper way:
    As you can see in the picture below, the light emission is cut very low on the facade, while to be correct it should reach a much bigger height on the wall.

         



    I had already tried before to make the same task with a previous version of Enscape (v 2.1.2.7-g050ffbb)... the result wasn't perfect but still acceptable (see image below).




    Is there any way to improve this?

    I mean, without in the meanwhile losing quality on the light effects of other types of outdoor lighting - e.g. road lighting, which has improved a lot from v2.1 to v.2.6.



    Any feedback is highly appreciated.


    Thanks a lot.

  • Thank you for your report Alessandro , in this case, would you be so very kind as to provide me with the project at hand? There seem to be some dramatic differences between 2.1 and 2.6 indeed, so receiving the project would be great for troubleshooting purposes. :)

  • Hi Alessandro,


    Thank you for sharing the file! We've had a look at it, and, unfortunately, this will be very difficult to fix for your case.

    The reason is that we're utilizing something like a half-sphere around every light source, limiting it's maximum interaction with the scene based on average collision distance. We've introduced this optimization in order to extend the range of lights in the first place, focusing the light "where it belongs".

    In this particular case, unfortunately, the result does not reach the entire wall.

    Any changes in the algorithms would lead to other lights losing range, and / or a heavily reduced performance in Enscape, I'm afraid.

    I'm very sorry I can't resolve this issue for you at the moment.

  • Hi Kaj,


    I have some further observations on this particular issue.


    I've tried to make some tests to better check the behaviour of the light fixtures.


    If I move on the vertical axis the fixtures of the model I already sent you, I see that the light effect changes a lot in relation to the height of the fixtures.



    Here is the effect when the lights are at the ground level (starting point):



    Here is the effect at 2m and 5m height:


         


    As you can see, the more the height, the more the light effect gets better.



    As a final test, here is the effect when lights are turned downwards:



    As you can see, here the light effect is optimal.




    So, here is my question: considering that the height of the fixture seems to be the only variable in the light effect, isn't there any way to fix the algorithm so the behaviour is always the same and not dependent on the height?



    Thanks.

  • Try seeing what it looks like with all materials which have "Self Illumination" ticked, and make them UNTICKED (in model and family). I puzzled over my model for a long time before trying this and it was like turning the lights on. Self illumination really throws out the exposure settings ... one bad material ruins everything.

  • The reason is that we're utilizing something like a half-sphere around every light source, limiting it's maximum interaction with the scene based on average collision distance. We've introduced this optimization in order to extend the range of lights in the first place, focusing the light "where it belongs".

    In this particular case, unfortunately, the result does not reach the entire wall.

    I'm actually working on an exterior rendering at the moment and noticed that the site area lighting wasn't doing much and thought it was an issue with the light itself. Never occurred to me that it would be limited within Enscape.


    Could this be modified somehow in the future with a parameter in the light fixtures or light grouping? Have either a yes/no parameter in the fixture that ignores the rendering sphere, or an adjustable range? It would need to be on a fixture type basis to really be effective, but it would be a good happy medium I think. People that really want/need the extra lighting get it with the trade off of longer calculation times.

  • I had a similiar issue trying to light a football field at night the lights are mounted on poles very high above the field. I couldn't get the light correct. my guess is its this same issue. so another vote for some sort of fix to allow for long throw lights. Maybe a check box or something for specific fixtures instead of adjusting everything. Or use the naming like you have with grass and carpet. IE we rename our light fixture with some key work to let enscape know to adjust the settings only for lights with "long throw" in them or whatever term is most accurate.

  • I agree - found this thread after trying to get my own uplighting to show correctly in a room (wasn't working in more complex model so went simple to verify).

    At ceiling height of 10ft the light cut out around 8' 9" away. With 14' 6" ceiling height this works to about 12' 2" away.


    Based on my own testing of a downlight and an uplight - and the study by Alessandro above - it looks like this works for lights aimed down but there is a bug for those aimed up. Maybe this half sphere range is bottom half vs upper half? Be nice to have a fix this for sure. Either disable as mentioned, or maybe enable full-sphere for selected fixtures (or all, with known slowdowns becoming acceptable).


    Appreciate the efforts to create faster render capabilities, but without the ability to accurately render uplights any measurable distance away from a surface (ie not a pendant over a desk) it is quite limiting for our use.