Section planes auto-activate on creation of new scene

  • (SU2019 Enscape 2.7 preview 4)

    When clicking on the button to "create scene", if I have a non-active section plane in my model, it automatically becomes active as the scene changes within SU (and is generated) to match the enscape window. This then updates the Enscape view to show the cut section when I didn't want it to.


    (I generally create the scene after I set something to start rendering an image... I'm just waiting for something to break as it starts to render and I quickly toggle the section off again.)

  • Gadget , I'm not able to reproduce this issue in preview 5, so it may very well be resolved in that version already, could you test it and let me know if you still experience this problem? :)

  • Preview 5: yup - same thing:


    - draw a box

    - add a section plane to intersect it

    - turn all the section plane buttons off (planes, cuts and fills)

    - click the create scene button


    SU both creates the scene and makes it the active scene. The scene that Enscape created has the "cuts" & "fills" activated and the Enscape window shows this.

  • Gadget , the workaround for the time being would be creating a scene through SketchUp itself with these visibility settings of your choice, and from there on create further scenes through Enscape, it should take over everything correctly.


    I'll forward this internally to see if we can do something about this, overall this behavior occur due to technical reasons / limitations regarding what information we're receiving from SketchUp.