New V2.7 Sync is jumpy on Windows 10

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Sketchup 2018

    Enscape 2.7 - Licensed

    Windows 10 x64

    Nvidia Gforce 1060 6gb display card

    16gb ram

    12 core processor i7

    All windows software is up to date including Nvidia drivers


    Hi there, since I have updated, when you rotate a model - simple or complex it make the live view sometimes jumpy

    Inside the viewport movement is smooth, but when you just preview as you rotate the model in Sketchup its jumpy.

    Does anyone have a solution or experience similar issues? :thumbsup:

  • I guess this will probably be looked at in future releases. I'm 200% happy with that they are doing and taking this product. My post was purely just to put this under their attention that it does skip a frame or so when rotating the actual model. Maybe in updates onward, this issue will be looked at. :thumbsup:

  • Don't know if this is the same thing: I have found that in every version of Enscape navigation within the Enscape window 'jitters' now & again. It's as if the navigation is too quick for the rendering and has to jump to catch up.

    To limit the effect I turn down the sensitivity of the spacemouse - the jumps are less noticeable when they are smaller.