Rhino 6/5 linear light, rectangular works like point light.

  • Hello,


    Does anyone have the same problem with linear light or rectangular light? I am trying to create a very simple cove light shown with the image. But they all rendered as point lights.

    How could I solve this problem?


    Thanks,

    Ray



  • Hi Ray G and welcome to our forums!


    Based on the right screenshot it doesn't look like it's beeing rendered as a point light to me. However area lights do have a size limit (3 meter) in Enscape. If you want larger area lights you'd either have to combine them from multiple light sources or as v-cube suggested use an emissive material instead. However you won't get as crisp illumination from an emissive material as you get from a light source.


    Hope that helps! :)

  • Thanks, Clemens, and v-cube for the quick responses.

    I see why they seem like point light when rendering large objects. I will try the multiple lights method.

    Yeah, I tried the emissive material earlier, but they are not very high quality. Also, does the emissive material related to the time of the day? The material seems only illuminating in the evening. Can I turn the light on during daytime in Enscape with emissive material? (illuminate both itself and the surrounding context)

  • Yeah, I tried the emissive material earlier, but they are not very high quality. Also, does the emissive material related to the time of the day? The material seems only illuminating in the evening. Can I turn the light on during daytime in Enscape with emissive material? (illuminate both itself and the surrounding context)

    Using a lot of emissive materials can indeed cause a bit of noise, maybe that's what you are referring to regarding the "not very high quality", but that should generally only occur in darker areas which are generally not that well lit in the first place.


    Emissive materials are also always emitting light, but it's just that when you set the time of day to anything but Night, the sunlight itself usually is so strong that it makes emissive surfaces look like they're not emitting light at all. You may want to, for example, reduce the "Sun Brightness" in the Atmosphere tab of the Visual Settings and/or also turn up the emissive light brightness. I don't know what you're going for exactly, but if you're going to do an indoor scene most of the light from the outside may also not affect the emissive surfaces too much, but this depends on the window size etc. regarding how much light can come in externally.