Tutorial: how to create custom Enscape assets

  • Maarsso, Thanks for the reply. Correct. I only have the other two files in that location. The assetdates and favorites are listed as .json files. But that's all.

    I have hidden files turned on in my view options also.

    I use Enscape in Rhino only. So not sure if this config file would be generated for Revit or Sketchup applications? It strikes very odd that I would be missing this file.


    There is a winpos.dat file in the Roaming directory.


    and a displayText.csv file in Roaming/Data/Localization


    But those files are not formatted with the same syntax structure as the config file shown in the tutorial.


    Hope the above context helps.

  • Hi there. Yes, that's the only account I use on this computer.


    Pieter Maarsso, I just solved this issue by going over to another machine of mine with my original Enscape install and found the file there. I simply copied the file over to this computer and everything seems to work fine now.

    The mystery still remains why I would be missing that config file in the first place - The only thing I can think of it is that it is a second install (from the website) and I "moved" my single seat license to this mobile workstation I'm using currently.

  • Hi All - Now that I've got the asset manager up and running and I've created my first custom asset, I'm seeing something unexpected with the Proxy outline object.

    I know that I need to use Meters for the proxy object, and I tested my first custom asset using the simple box placeholder at first.


    However, when I re-created the Custom asset and used a custom OBJ object placeholder (Again - just a simple 12 poly cube from exported from Max)

    Something weird happens:


    I can insert the asset no problem - Select surface - place the item.

    But nothing is displayed.

    I start the Enscape viewer and the Item is rendered as I've placed it.


    Then it gets weirder. - I can select the placeholder by block name or by doing a crossing or window selection where it should be displayed.

    It actually shows the gumball while the invisible item is selected. I just can't see anything.


    I've checked visibility settings and layer settings but can't get anything to show up in Rhino.


    I've tried this in multiple files (Some started from scratch to test) with the same result.

    The Box setting seems to work fine


    I'm running Rhino 6 - SR 2.8 with Enscape 2.8.0

    Asset Generator v1.3


  • Sure:

    The placeholder table's dimensions should be (As listed in Max)

    X = 2.157 m

    Y = .968 m

    Z = .824 m


    I've included all the related files to the asset for your convenience.

    I've also included a Test Rhino file where I've inserted the table onto a surface. (It's invisible but sitting at the center of simple ground plane)

    If I start Enscape it's sitting where it should be at the correct scale.


    As I'm attempting several iterations to figure this out, it seems to be scale related - If a scale the OBJ in Max up to say X=88 m then the Outline becomes visible in Rhino, but vastly overscaled to the actual .gltf asset.


    Thanks for all the help.

  • Pieter,

    Thank you for this useful tip. If you could please help out, I can't make make this backpack material show up as Enscape asset. I used SK2019, Enscape 2.8, and Blender. I checked there's no space in material file name, and it doesn't look like there's any space. I linked SK file, and bin/gltf exported from Blender.


    [Blocked Image: https://i.imgur.com/HpVcBah.jpg]

    https://www.dropbox.com/s/p5d1…ackpack%20Yellow.skp?dl=0

    https://www.dropbox.com/s/h453…ckpack%20Yellow.gltf?dl=0

    https://www.dropbox.com/s/9ra5…ackpack%20Yellow.bin?dl=0

  • Hi Peter,

    I was able to create the asset, but had trouble to make the placeholder. I don not see Enscape Asset collection or Enscape Placeholder collection. Can you upload a screenshot of where exactly to find those?

  • Thanks Pieter,


    Yes, I'm using the Box option for the moment and sizing i accordingly.

    I'll try merging the three objects to see if that produces a different result.

    Enjoy your holiday - let me know if you find anything else that might be causing the weirdness once you circle back around.


    Thanks for all your effort on this app.

  • Hi Peter,

    I was able to create the asset, but had trouble to make the placeholder. I don not see Enscape Asset collection or Enscape Placeholder collection. Can you upload a screenshot of where exactly to find those?

    The tutorial suggests those are mandatory, when they're in fact not.


    Create the placeholder model, and make make it a single object. Move it on the actual 3D model. Select it, and do the *.OBJ export, with the "selected geometry" selected.


    I've created tens of assets and I've never a) joined all the meshes into a single mesh or b) created the layers and they've always worked pretty well.