Consistency of zoom / crop on repeated batch renders

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Hi,


    I've got project with multiple 3d perspective and orthographic view set up, each having been created in Enscape (with Create 3D view). I've then set up Profiles and linked them to each view (lighting, ortho vs perspective etc). Now, between subsequent batch renders, the zoom level of the view seems to change - sometimes the model fills the extent of the render (as expected) sometimes it's zoomed way out and it's tiny and sitting in the middle of blank space.


    This is incredibly frustrating, as I have multple Photoshop drawings set up with the renders as linked images and associated masks etc. When I re-render and re-link to Photoshop the images have changed size and don't align with the masks etc...


    It's so close to be fantastic for using renders (especially ortho) in formal documents, but if we can't ensure repeatability it's a nightmare!


    Thanks

    Rob

  • Just as a follow-up, part of the problem I was having was that it appears that Enscape is not updating its default position of a view if that view is changed. I had an ortho top down plan, the view itself created from Enscape. I then later change the scope box to show a larger area, but Enscape would always open this at the original position, and renders would be offset / clipped. If I re-created the view from Enscape it would then be correct, with the new larger view correctly centred...


    not sure if this is expected behaviour or a quirk...

    • Official Post

    Welcome to our forum rob_boltman , pardon about the late response.


    So at the moment the full camera location info is not saved (or used) alongside when an Orthographic perspective is being used in Views and such. I'm forwarding this for discussion to our developers, there may be some technical limitations which are causing this behavior.

  • Really?


    So basically there is no way to save a specific AXO view crop from Revit to Enscape?


    I am actually experiencing this, but I thought I was missing something... No matter how I tweak the crop of my revit axo, the Enscape view does not change... Even Safe Frame is useless...


    So I have to tweak the view on Enscape, render and the next time I will not able to re-render the exact same crop/view...


    This needs to be fixed.


    thank you!


    regards

  • Hi Rob = There's something buggy going on in Revit when you switch between Ortho and Perspective mode without a view boundary. You can test this by setting the view scale in Ortho and Zoom to Fit. Then change to Perspective and zoom to fit. Change back to Ortho - the scale has changed! Do this a few times and then building will zoom out very far in Perspective mode.


    To stop this from happening (and creating a consistent view for Enscape to render) turn on the Crop Region / Boundary for the Perspective View. Then Enscape will render consistently because Revit is behaving consistently.