Enscape 2.7 installation / update troubles

Please note: Should you experience issues with Enscape or your subscription, and in case of any urgent inquiries/questions (e.g. regarding our upcoming licensing changes) please reach out to our dedicated support team via the Help Center or Support button as detailed here.
  • There's a nasty snag in the way Enscape 2.7 is installed / updated. As from version 2.6, the package comes as MSI installer. We install Enscape updates unattended from the domains shutdown script since version 1.8. This has always worked without problem. When the MSI-version installer was introduced, it did not automatically remove the older, setup.exe version. Still no problem.

    With version 2.7, things have changed. We use this line to install Enscape: msiexec.exe /i "Enscape-2.7.0+18848.msi" /passive ACCEPTEULA=1 ALLUSERS=1 SKIPREQUIREMENTS=1 INSTALLLEVEL=0 ADDLOCAL=Enscape,Revit There are several issues.

    First issue: it needs a VCRedist which is NOT installed using the unattend mode. As a result, Enscape won't start properly.

    Second issue: when I try a 'manual' reinstall to fix the first issue, I can only install it in the currently logged on users profile (yes, I did click the Advanced button). IMHO this is by default a BAD practice since it introduces a serious security risk. So I need to uninstall Enscape before I can reinstall it for all users.

    This is where the third issue pops up: if I want to uninstall Enscape from the Programs control panel, it throws a message I should issue the option EULA=1 and stops without removing Enscape. I have to remove Enscape using the command line above, changing /i to /x and I have to perform this a couple of times before Enscape is really gone.

    Only NOW I'm able to install Enscape for all users.

    BTW the most recent version (Enscape-2.7.1+20886.msi) also behaves as described above.


  • Reading back my own message, it dawns to me option SKIPREQUIREMENTS=1 is very likely the cause of VCRedist not getting installed. When set to 0, the installation waits for input on installing - not very handy for unattended installs.

    The Enscape System Requirements do not specify the needed VCRedist so one has to rely on a manual install to find out the prerequisites.


  • Thanks for the feedback. I'll look into including this information into the System Requirements, so thanks for bringing this to my attention.