Installing extension results in error message

  • We were having problems installing the extension on Sketchup Pro 2016. Could not find any mention of the problem we were having.


    The error popped up after restarting Sketchup:

    Error: #<LoadError: 126: The specified module could not be found. - c:/users/boardroom/appdata/roaming/sketchup/sketchup 2016/sketchup/plugins/enscape/Bin64/EnscapeSketchupPluginHost.so>

    C:/Program Files/SketchUp/SketchUp 2016/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require'

    C:/Program Files/SketchUp/SketchUp 2016/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in `require'

    c:/users/boardroom/appdata/roaming/sketchup/sketchup 2016/sketchup/plugins/enscape/loader.rbe:19:in `<main>'

    C:/Program Files/SketchUp/SketchUp 2016/Tools/extensions.rb:197:in `eval'

    C:/Program Files/SketchUp/SketchUp 2016/Tools/extensions.rb:197:in `require'

    C:/Program Files/SketchUp/SketchUp 2016/Tools/extensions.rb:197:in `load'

    C:/Users/boardroom/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/enscape.rb:9:in `register_extension'

    C:/Users/boardroom/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/enscape.rb:9:in `<top (required)>'


    We tried many things, different profiles, reinstalling Sketchup, but found that installing the Visual Studio 2017 Community package windows and dotnet components allowed Enscape to run. Have not determined which of the components are specifically fixing the issue.


    hope this helps. T

  • Your error message has two possible root causes:


    1) You don't have the .../plugins/Bin64/EnscapeSketchupPluginHost.so file. This file is copied from Bin64Stage directory by our small ruby script. This can fail, e.g. if you have restrictive file system permissions.


    2) The .so file can not be loaded. You do need .NET Runtime v4.0.30319. We compile against .NET Framework 4.5.2, although another version might also work. I guess you have Windows 7 because since Windows 8 .NET 4.5 is included. Is this correct?

  • Yes, Windows 7.


    All domain profiles on our Windows desktop machines have full Administrator permissions.


    So just ensuring that at least NET Framework 4.5.2 is installed should allow the extension to run?

    That would be quicker than installing Visual Studio modules.


    I will test on another workstation.


    Thanks for the information.

    T

  • Just a follow-up on this topic:


    Enscape for SketchUp has two external dependencies:

    - Microsoft .NET Framework 4.5.2 - Download at https://www.microsoft.com/download/details.aspx?id=42643

    - Microsoft Visual C++ 2015 Redistributable - Download at https://www.microsoft.com/download/details.aspx?id=53840


    SketchUp 2017 installs both, so you should not have any problems.

    When using SketchUp 2016, you have to install them manually if you have problems.

  • I downloaded and installed Trial Enscape today, but several errors appeared as soon as I opened SketchUp. Attached are the images of the errors and the versions of the softwares installed on my computer. Thank you for any help.


    Load Errors

    Error Loading File C:/Users/Érico/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/enscape/loader.rb

    Error: C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in `require'

    C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in `load'

    C:/Users/Érico/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/enscape.rb:9:in `register_extension'

    C:/Users/Érico/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/enscape.rb:9:in `<top (required)>'

  • Hello,


    There is my problem:

    Error Loading File C:/Users/Администратор/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/enscape/loader.rb

    Error: C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `require'

    C:/PROGRA~1/SketchUp/SKETCH~1/Tools/extensions.rb:197:in `load'

    C:/Users/Администратор/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/enscape.rb:9:in `register_extension'

    C:/Users/Администратор/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/enscape.rb:9:in `<top (required)>'


    I had installed Enscape, and it worked, but not in 100% good - i didnt have materials. So I decided delete and reinstall enscape plugin, but after that I can't do anything, all the time I see that errors.


    Please help.

  • Hey bozhena171 ,


    Welcome to the Enscape forums!

    I'm sorry to hear you're running into problems.

    Can you tell me when this message shows up? When you try to start Enscape?

    Did you receive a prompt to send us Feedback? If so, please do so and we should get all the data necessary to help you.


    If not, please let me know!

  • Hello,


    Thank you for your answer.

    I see error message all the time when I'm start opening the SketchUp.

    Also I see Enscape in Extension Manager, but it has grey (inactive) icon.

    I don't see Enscape in my toolbars, so I can't send you Feedback, mayby there is another way, but I don't know about it.

  • Hi bozhena171 ,


    Can you please try uninstalling Enscape using the Windows "Programs and Features" function, and install it again?

    Once you've done that, can you please check if you can open the Enscape menu under "Extensions"? There should be a "Feedback" menu item that you should be able to use to send us feedback. Please let me know once you did so.

  • Ok. I did everythink you ask me about. And nothink happend. I installed from Extention Warehouse, i think it is older version "enscape-2.0.2.9-gb65fd4e" there is the name of .rbz file. And its going fine but I dont have here Enscape materials. I sended Feedback, for which you asked me. The title or subject is: Enscape materials.


    Thanks

  • bozhena171 , thanks for getting back to us. Since you've just installed an older version of Enscape, 2.0.2.9 instead of 2.5.3 (our latest release), you'll also not have the material editor included. In the next step, would you be so very kind as to download our latest release and this time, install it for "all users":


    That could very well already help with resolving your problems. If it doesn't you can also kindly try to re-install Enscape once more into another folder, so that the path over all does not contain any Russian letters (in this case it's your username Администратор which could cause these problems).


    Thank you in advance!