Does more RAM help? + another performance question

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.
  • Hey everyone,


    I wondered something and hopefully I can drop my performance questions in this SU topic.


    Most of the times in my fairly heavy projects, during rendering and such, I see that about 12 to 16 gb from my 32 gb ram is being used , so this looks like I have way more room space for the tools I'm using. But 1. is there a way I can make better use of my ram memory and 2. would it matter if I added even more ram?


    And since I'm already talking about performance: Alot of times I see my cpu (ryzen 7 1700x), my ram and my gpu (2070 super) having no problems at all. Ram as mentioned above and both cpu + gpu below 10% when I'm modelling in SU (with Enscape). And still SU manages to make me wait quite some time for certain actions, working with skatter, the sandbox tool or just random short (few seconds) freezes.

    Does anyone recognize this as well and is SU just particularly poorly written or are there some settings I might tweak to get more power out of my system?

  • Sketchup is slow, it is not the fault of your system and adding more RAM wouldn't make any difference.


    A CPU with a higher clock speed could help a bit, and I guess Enscape could utilize an even better GPU (but the 2070 super should be plenty), but what you are experiencing is really Sketchup's fault, not a deficiency of your system.


    Try the following: Keep your materials and outliner panels closed at all times, and open them only when you need them. Sketchup has some bugs which make certain actions slower when those panels are open, especially when working with larger models. Also, keep shadows off, and turn them on only when you need them. Lastly in "View -> Edge Style" have only "Edges" turned on, and turn off "Profiles" and everything else.

  • There's a bunch of threads on the official Trimble SketchUp forums that report massive speed drops when using the Outliner. Zoom already mentioned some good points (shadows off, profiles off etc.), I also found excessive file size bloat to be a performance killer - therefore I regularly check the project with Material Resizer to catch any excessively huge textures. Also using Layers (or now called "Tags" in SKP2020) let you turn off unneeded geometry and therefore improve performance.