Enscape installation causes sketchup plugins to display a security warning

Please cast your votes in our two ongoing feedback polls here and here!
  • Hello, I purchased a new laptop with single hard drive and was installing sketchup along with plugins including enscape from my old computer. After installing and opening sketchup, some of my plugins such as the sketchucation plugin manager displayed a security prompt:

    "to help protect you security your web browser has restricted this file from showing active content that could access your computer click here for options"

    After research, I found a post on sketchucation that had the same issue. It noted that after uninstalling enscape, it fixed the issue.

    I also tried uninstalling enscape and it fixed the issue. Therefore I am assuming that it may have to do with Enscape.

    Sketchucation Post:


    To use the sketchup plugins, I need to click on the prompt and enable activex controls, which is quite a pain because keeps opening each time I open sketchup.

    In my last computer, I installed sketchup on the external hard disk, which maybe why it did not occur before.

    I tried both 2.8 and 2.72 and had the same results.



  • lkwongfai

    Changed the title of the thread from “Enscape installation causes sketchup plugins to display a IE security warning” to “Enscape installation causes sketchup plugins to display a security warning”.
  • lkwongfai , I'm sorry to hear about that.

    In the first instance, please send in a feedback report:


    You can add what you wrote here in the submission form, or even more easy, simply add "To Demian" in the title, and/or include a link to this forum thread for reference. That would be very helpful for further troubleshooting, thank you very much in advance!

  • HI,

    I have the same problem on my PC , I have already submitted my feedback and info.

    I have try reinstall sketchup and enscape but still cant solved the problem.

    My plugin work if uninstall enscape, that give me big problem now .

    Hope yours can escalate to solve it .

    Thank you.

  • hoangleo and KHTAN , welcome to our forum. hoangleo please also kindly send in a feedback report as stated by my last reply, you can also add a link to this thread for reference. :)

    We'll have a look KHTAN , thank you too.

  • We're onto it everyone. I'm sorry that you're experiencing this at the moment, but we'll try to find a solution as soon as possible.

  • I think i've found some trick to solve this problem. You just need to disabled the Enscape from Extension Manager (Window -> Extension Manager -> disabled Enscape). When you re-open the Sketchup, everything will be alright. If you want to use Enscape, just enable it, but don't forget to disable the Enscape again before you close the Sketchup. Give it a try.

  • We're still looking into it, thanks for a bit more patience.

  • Right now we cannot reproduce this issue ourselves I'm afraid - you are using SketchUp 2018, correct? Also, which version of the Internet Explorer is currently installed on your machine?

    You can check this through the About window of the Explorer:

    Thank you so much for your help in troubleshooting this. :)

  • Hi everyone,

    i just wanted to know how the Status of the Solution is? Our Office will maybe switch the renderengine and i just try all products out (Lumion, Twinmotion, Enscape etc. at the moment we use Vray with SketchUp) With that problem, i cant barley use SketchUp. Important Plug-Ins are not really useable with enscape. With no solution it will disqualify enscape. Is this a Problem with the new version 2.8 or was this also an Problem with the older versions?

    The big Plus of enscape are the combinability with skatter, transmutr and the quixel Bridge. With the Assets of Enscape plus the assest of quixel it has huge lead to the other Programms. But wenn the PlugIns of Sketchup dont work, the adventage of enscape is gone... I hope really you find a quick solution.

    btw, we work with SketchUp 2020 (but the Problem is also on the older Version 2019..) an i have the actual trial version of enscape... Browser Version is

    i hope it helps... best regard from germany...

  • Can you try the following: