How to match SketchUp scenes perfectly for batch render?

Reminder: If you encounter any issues with Enscape (including installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed here. Thank you for your understanding.
  • Hi there,


    We can't seem to get our SU scenes match the batch rendered ones properly. The best match is still rendering the scenes individually. What would we the correct way to batch render?


    If I understood right, the right way to set up SketchUp views for batch render is to preview them (with sync off??) in the enscape window and use the create scene button, right? This way I can preview them in the enscape windows "views" tab and correctly render them. Only thing is that the default enscape window might not be perfectly 16:9? Or is it? I noticed the view gets rendered with more pixels on top & bottom but width fits perfectly. Is there a way to set my preview window to be perfectly 16:9? Read something about Enscape and SketchUp using horizontal / vertical FOV or so and that might cause the inconsistency?


    Did I understand the secret to perfect Sketchup batch renders right? Create scene in the enscape preview?


    PS: Never understood the "use viewport aspect ratio" really - in what case would I use the option?


    Thank you!

  • I can help with that, took me ages to figure out why it wasnt working. So first you have to unsynchronize views (blue arrow cam) and next you will set your desire views within Enscape's window, when you are happy with the view you save it with the Enscape "Create scene". Now that you have all you scenes, if you want to render batch you have to keep sync views off and select the views you wanna render and it will all be good.

    Notice: sometimes it takes cut plane in consideration, no idea why BUT, I found that if you update your scene without the plane, it will still work.


    for the pixels that Enscape cuts, I'm not sure at all if it is possible to get rid of it...only in solo rendering I found on previsualization.

  • whether it is the correct way or not - this is the way I/we always go:

    We, the entire SkUp team and I reset the SketchUp viewport to our preferred aspect ratio first to define our scenes. Also in our case this is usually the HD aspect ratio, e.g. 1920 x 1080 or a multiple of it. Within SketchUp it is not important how big the aspect ratio is actually, what is important is the viewport´s determined ratio of width to height! So we guarantee an always identical, fully SkUp-synchronized and always else- and everywhere reproducible render view. This procedure is very simple and works with Synchronize Views. To reset SkUp's viewport to our desired sice we use Julia Christina Eneroth's "Resize Viewport" plugin.
    https://sketchucation.com/pluginstore?pln=ene_resizer
    hope this way could help you as well ;)

  • Thanks Egie. This looks like to be perfect for single export of individual scenes with perfect control over size and aspect ration. Batch export seems to be a different process all together so for that we will continue to create scenes via Enscape preview window, unsynced and batch render with sync off.


    Still looking for a way to set the Enscape preview window to a certain aspect ratio - any way this is possible?

    • Official Post

    Thanks Egie. This looks like to be perfect for single export of individual scenes with perfect control over size and aspect ration. Batch export seems to be a different process all together so for that we will continue to create scenes via Enscape preview window, unsynced and batch render with sync off.


    Still looking for a way to set the Enscape preview window to a certain aspect ratio - any way this is possible?

    That is not yet possible, but should be soon, since this is planned to be available when using the Video Editor. (By displaying the safe frame)

  • I can help with that, took me ages to figure out why it wasnt working. So first you have to unsynchronize views (blue arrow cam) and next you will set your desire views within Enscape's window, when you are happy with the view you save it with the Enscape "Create scene". Now that you have all you scenes, if you want to render batch you have to keep sync views off and select the views you wanna render and it will all be good.

    Notice: sometimes it takes cut plane in consideration, no idea why BUT, I found that if you update your scene without the plane, it will still work.


    for the pixels that Enscape cuts, I'm not sure at all if it is possible to get rid of it...only in solo rendering I found on previsualization.

    You are awesome! I have been going insane wondering why some models/views worked well and others "zoomed out". I must have been creating some scenes while synced, and others while not synched. Some from setting the desired view in Sketchup, others in Enscape.


    This actually resolved the problem with the view "jumping back" , which was occurring in Enscape when I toggled between sync/unsync.


    So note to self, create views in Enscape, while Sketchup is not synced, then sync afterward. No more jumping back :)