Posts by Paul Russam

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.

    I've written a Windows Powershell script that will go through the entire Enscape offline assets folder and COPY the thumbnails to another folder with the correct asset names but before I post it I'd like permission from Enscape to do so.


    • As it's a script it's completely readable in any text editor so you'll be able to see all the code.
    • It doesn't do anything to the offline assets other than read the contents of the folder(s).
    • You can set the source folder of your offline assets.
    • You can set the destination folder for the new named thumbnails.
    • You can set the language that the thumbnails and category folders use for their names!!
    • You can repeat the process next time the Library is updated.
    • It only takes a few seconds to run


    I've found a way to be able to automatically print each category folder to a PDF with 20 thumbs per page but it involves installing a .NET library so I'll look at that separately, for now, they can be printed manually using whatever app is best.


    Kaj Burival  Clemens Musterle

    I don't use the Custom Assets at all, I have Transmutr which will import obj/fbx etc into SketchUp AND importantly allow me to reduce the poly count so I can get the best compromise between size and quality.

    In Transmutr you can relink supplied material maps ... if the model isn't like you describe above,

    Once imported into SU I'll rename materials to my liking, do all the usual Enscape stuff of shininess, bump etc etc and then save it as a proxyable standalone model.

    Doing it this way, if I need a variation of the model (think bed with blue pillows > green pillows) it's a simple exercise of copying the bed model, changing its materials and saving for use.


    https://lindale.io/transmutr

    Happens to me a lot, it comes down to how well the original uploader prepped AND CHECKED what they exported. Sometimes they may only upload 1 format (fbx/max for example) and then it’s down to the host site (CGTrader/turbosquid etc) to make the other formats.

    I’d say 60% of all the content I’ve ever downloaded has had materials screwed up of even non at all.

    Was SketchUp installed correctly?


    It’s absolutely necessary to right click on the installer and select “install as administrator”.

    Being a user with administrator privileges is NOT the same.

    Without the above some plugins will not work.


    As you have 2022 already installed you can select ‘repair’ during the installation process and it will perform the necessary changes to your existing install.


    In Windows, have a look in C:\Program Files\Enscape\Renderer\SystemData\Textures\Horizons (I don't know about MacOS location)

    You'll find all the std ones that ship with Enscape.

    I don't know if you can add a new one or if you'll have to replace an existing one but as long as you match the size/format etc it 'should' work.


    WARNING!!

    You'll be doing this at your own risk, we users are not meant to modify stuff in the Program Files folders

    Any Enscape update will almost definitely overwrite any changes you make with the std ones so backup!

    if Enscape could apply a different proxy "shape" instead of the clear wire frame to these proxies via "linked models."

    I have a bucket load of bed, sofa etc and like you the simple wireframe cube isn’t good enough, what I do is create as simple a shape as possible that represents the bed/sofa with the correct length/width/height/shape and then edit the wireframe component replacing the wires with the simple shape.

    I then save this simple poly to the same folder as the original hi-poly one.


    My usual naming structure would be something like:

    • Bed01-mat01-fullgeometry.skp (the original hi-poly model)
    • Bed01-mat01.skp (the simple proxy model)

    Material variations of the same bed will get mat02, mat03 etc

    And a new bed will get Bed02, Bed03 etc.


    Essentially the process is “I like that bed but can it have green pillows” at which point I copy the fullgeometry model, rename it next in the mat sequence, edit it, save it and then in a new SU model; insert a previous version’s proxy, re-link the proxy to the new bed edit it to have the simple geometry and right-click/save as to create the new simple proxy. (Sounds long/complex but isn’t, if anything it’s tedious)

    Well, there’s me put in my place :)

    When you put it like that you’re quite right.


    I suppose the question is ‘how do we establish/apply the initial setting(s) from which we can then deviate(if needed) per scene?’


    Let’s say I’ve setup 20 panos with 1 setting and now I want to setup 20stills with a new one.

    Currently I have 2 settings called ‘panos’ and ‘stills’, in the future how do you picture the process of applying the stills setting whilst simultaneously modifying it per scene WITHOUT upsetting the already setup panos?


    This isn’t a challenge by the way, it’s something Enscape is going to have to work out and we’re going to use so thinking about it now ‘may’ influence their methodology.

    This is an older thread but very relevant RE: Duplicate views, select/change preset of multiple views & other QoL features


    In the recent poll as to how much of the visual settings should be in the individual views I chose the 2nd option (partial). If you produce 1 or 2 views from a model I can see the attraction of the 3rd option (full) but I usually knock out 20 or 30 views and I need a consistent look to all of them, if I want a slightly lower/higher exposure I can currently; and with the 2nd option make that change once. With the 3rd option; with the exposure (and other relevant settings) in the views I have to make it for every scene.

    Something I’d like to see is the visual settings being accessible from outside of the Enscape window.

    Scenario:

    I’m working on a model and I want to use the settings I used in a past model and they weren’t saved as external files at the time.

    I have to close my current model, open the old model, fire up Enscape, wait, wait, wait, save the settings, close the model, reopen the one I’m working on, fire up Enscape, wait wait wait, and finally import the settings.


    I don’t need to edit them, just import them from one model into the current one.

    a dead simple checkbox in the settings menu

    I’m perfectly happy to have that but the current setup (ie compressed) should be the default. If you want to have uncompressed/full fat textures you should be the one(s) burdened to change the checkbox.

    This forum is only visited by a small % of users and an even a smaller % ever comment, this thread has only 8 users (me included), I just don’t think it’s something the vast vast majority of Enscape users care about.

    0.9mm .. whist it’s nice to have real world accuracy it’s unnecessary for a lot of stuff.

    It’s important that the wall is the correct height/width etc but an exact replication of its thickness and profile isn’t. I see this (and catch myself doing it) a lot.

    I build models of buildings, not real ones (I leave that to builders) and as such I can simplify or even omit a lot of stuff, as a grossly simplified example it’s totally unnecessary to model the wires between a switch and a ceiling light even though they will exist in the real building BUT I will model something that looks like the switch and light.

    what's the point or correct use of 'auto exposure'?

    I'm not the best to ask as I tend to throw settings at things and stop when it looks ok.


    You're very close to the doors in that view, you may want to try turning AE back on and back up a bit so there's more of the room (less of the sky) in the shot, the exposure will be better/more balanced and you can always crop the rendered still after.

    When I'm setting up shots for my DTP colleagues I set up what 'I' think is a good shot and then back up a bit before saving the scene, this way they can crop the resulting render down in Indesign to what they 'need' for their compositions.

    It’s auto exposing, there’s more light coming from the outside without the roof so it’s automatically lowered the exposure ‘for the whole scene’ to compensate.

    You could try turning off auto exposure in the settings and adjusting the value to suit both setups.