Posts by Prosberg

    I've been testing Oculus Quest / Shadow Cloud / Virtual Desktop / Enscape. This uses an external cloud server (Shadow) to stream to the HMD - the results are very promising, however there still is some lag, and the navigation in VR needs some calibration. I ran tests using a very large .exe-model exported from Enscape, with maximum rendering quality. The Shadow cloud uses a GTX 1080, and this was pushed to it's max capability - with lower graphics settings, the lag was reduced significantly. I had an average latency of about 80 ms (which is still too much).


    With attention to constructing the model in an optimized fashion, I believe this could very well could work. The same setup is used to stream high-end PC-games to the Quest (which works fine). Compared to the ALVR-setup discussued previously in this thread, I think this works better and is more flexible (doesn't require a gaming PC/laptop), only fast internet and WiFi. However, the setup process is quite comprehensive. But this seems to be possible, and a total game-changer.


    @Enscape - you should host our own cloud server with some powerful GPU's :D

    Sean Farrell  Demian Gutberlet - Thanks a lot for both of your responses.



    Sean Farrell - I've tested exactly what you are describing, but getting these settings correct is practically impossible - even placing the headset on the ground to begin with doesn't change anything - it is locked to the height set in the Oculus device settings.


    Please note that these things doesn't translate well to a normal screen, so taking a screenshot is not of any great help - I have therefore made to pictures, that should help to explain this, see attachments.


    Picture 1: By entering for example 180 cm in the Oculus settings, the height becomes +20 cm (200 cm total) - as you also stated - but with this setting, the scale/proportions are way off - for example a door being 3 cm thick, looks about 1 cm - very strange phenomenon.


    Picture 2: By entering 160 cm in the Oculus settings (which gives approx. 180 cm in total) the scale/proportions are better, but still not quite correct. But now the perceived ground level in VR is off, giving the feeling the perceived ground level is +20 cm,


    Note - changing the spectator-height in the .exe -standalone does not have any affect.


    This could be related to the interpupillary distance (IPD) - please see this Reddit post, which discuss this issue - https://www.reddit.com/r/oculu…plain_ipd_scaling_issues/


    But as many people also state in this Reddit post, the player height should be determined with proper tracking.

    I've never seen any other VR-apps that lets you adjust the "spectator height", as is the case in the .exe -standalone.


    Thank you for your time. :)


    Update: this is related to the "floor position" set in Oculus Rift device settings.


    In order to have to right scale in Enscape, the floor position in Oculus device settings must match the height set in the .exe -standalone.


    I'm 180 cm, and setting the floor height to 160 cm in both settings menu, seems to make the eye-level correct.


    However, this is still not correct, as I'm now feeling like I'm 160 cm in Enscape, which gives a very weird experience. ^^


    So something about the spectator height/floor position for Oculus (or HMD's in general) is not right.

    Hi Demian,


    Thank you for your quick response. Yes, the settings are set to roomscale and walkmode.


    I believe this is related to the eye-height, as described in this post: Eye height


    I have tried many different settings now (this occurs in both the editor itself launched through SketchUp, and also in the .exe -standalone). No matter what the initial height of the VR-headset is, it always the same height - I'm 180 cm, and a 210 cm door seems to be just above my head - I seem too tall when standing up.


    In the .exe -standalone, it is possible to set the "spectator height", however, this has no effect.


    It seems to add some height when standing, as the "seated" mode seems OK.