Posts by JDD

    Hi there,

    I've try to ask the same question (using exactly the same wording as above) to ChatGPT AI engine.

    Here after the anwer of the robot :

    To create a horizon background file that will work well with Enscape, you will need to follow a few steps:

    1. First, you will need to create a 360-degree panorama. There are many ways to do this, including using a specialized camera or stitching together multiple photographs.
    2. Once you have your panorama, you will need to resize it to the correct dimensions, which are 4096 x 700 pixels. You can use an image editing software such as Adobe Photoshop or GIMP to do this.
    3. You will also need to ensure that the horizon line is located approximately 315 pixels from the top of the image. This is because Enscape uses the horizon line as a reference point for the sky and ground in the virtual environment. If the horizon line is not in the correct location, the sky and ground may not align correctly in the Enscape view.
    4. Finally, you will need to save your panorama as a PNG file. This file format is recommended because it supports transparency, which can be useful when blending the horizon into the Enscape environment.

    Once you have completed these steps, your custom horizon background file should work well with Enscape. Keep in mind that the quality of the final result will depend on the quality of your original panorama, so it is important to use a high-resolution image to get the best results.

    What's do yo think about this answer, correct or not ? Incredible !

    Hi there,

    All horizon background files provided with Enscape and located in ..\Enscape\Renderer\SystemData\Textures\Horizons, are in PNG format and 4096 x 700 px (72dpi) resolution.

    But how to create my own horizon file working well with this same resolution?

    It seams also that the horizon line is not located at half height (350 px) of the panorama but closer to 315 px

    What is the correct workflow I've to follow with my own 360 panorama to reach same result as the one supplied in Enscape ?


    my preference for running *.rb scripts directly is to use the following plugin.

    On-Demand Ruby / Extension Loader for SketchUp by Alex Schreyer

    Personnaly I prefer the one writen by "Aerilius" and available at SketchUp Pluging Store HERE, as you can see in above screenshots.

    Here attached (in a ZIP container) the script above but rewriten as a plugin (JDD_SortPages.rbz), so no need to reload it each time in the console.

    When installed , it will be available in "View" SketchUp menu toolbar as " Sort Pages (scenes) in Alphabetical order".

    Just remane the .zip extension to .rbz before installation


    The following Ruby code is better than the one above. Please use this one.


    I was hoping to rearrange the scenes to be in alphabetical order... not rename them.

    So, in this case you could try this code in sketchUp Ruby Console.

    You can save it with .rb extension using the name you want and place it in your Sketchup "Plugins" folder. Then you can reload any time you need this script using the SketchUp Ruby Console with the command load "myscript.rb"

    See attached screenshot on an example


    .., I just looked thoroughly for a simply ruby script to reorder scenes by name in Sketchup

    If you want a single ruby script to batch reorder scenes by name in Sketchup, here a simple solution you could try:

    This single line ruby script will rename all scene tabs in order with a prefix of your choise, for example 'ESC1', 'ESC2','ESC3' etc..

    A dialog box lets you type any desired "Prefix"

    n=inputbox(["Prefix: "],["N"],"Scene_Rename");Sketchup.active_model.pages.each_with_index{|p,i|"#{n[0]} #{i+1}"}if n;puts

    Simply Copy Paste and Enter this code into the SketchUp Ruby console.

    Here some screenshots

    Wondering if anyone here has experience using Curic Scene Manager plugin?

    Yes, Curic Scene Manager is a very good plugin to manage scene in SketchUp, and it's Free.

    Curic Scene Manager requires an additional Curic plugin, Curic Sections, to benefit from all its possibilities (send to Layout, Export to DXF an Update Section)


    I have to add a letter prefix to all of my views to see them listed the way I want in Enscape, which is a waste of time and actually falls apart if I then have to insert extra views.

    In the meantime, you can use the SceneRename plugin from Smustard in SketchUp, which allows you to rename and renumber all the scenes in just one click.

    This free plugin is available HERE

    At the end of the day, I was able to accomplish it in Photoshop using the warp tool to get the general effect.

    If not confidential, could you be so kind as to publish here some effects you've got with your method ?

    Hey ZO,

    For Piping line only, I'm using a very old plugin called lines2tubes.rb and written by Didier Bur

    Can be downloaded from HERE

    This plugin will turn a bunch of lines, arcs, circles, curves, etc. into cylinders of a given diameter.

    It doesn't matter if they are connected, just select the linework, go to Tools --> "Convert circles, arcs, curves, lines to cylinders".

    Personally, all lines, curves, arcs, etc. of the pipe routing are connected using the Weld plugin (from TIG or from Smustard) prior to apply this plugin.

    Additional information.

    If "Synchronize View" is OFF and if in the Visual Aspect Windows settings, FOV is forced to 38°, then the Bath Render results are OK.

    On all my scenes, in SketchUp, camera Fov(H) is set to 19.8° and the corresponding Fov(w) is 38.1° (see attached screenshot)

    Windows 10 Pro (21h2) | SkechUp Pro 2021 (21-1-1-332) | / Enscape 3.3.0+74199


    Batch render seems not working properly with 3.3 and SketchUp

    All scenes in my model have the same camera settings with a FOV set at 20 degrees

    With Synchronize Views ON, Batch Render of all scenes doesn't keep the FOV of 20 degrees in the render, and rendering is toggle with an FOV of 90 degrees, in my case.

    It is like Synchronize Views is toggle to OFF when batch render is starting.

    But, If each scene are rendered separately, one by one, the render is correct.

    Here attached :

    1- SketchUp Screenshot, 2 - Image of one scene rendered using Bach Render, 3 -Same scene render separately

    I've got same problem with another model tested.