Posts by josephkim626

Reminder: If you encounter any issues with Enscape (including installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed here. Thank you for your understanding.

    I've just had similar issues whilst changing assets to the new variants.


    I thought switching it to 'online' would do the trick, but it didn't reset the library.


    Had to delete the folder as it was instructed here.


    Then it solved my problem.

    That's a good question of course, thanks a lot for asking.


    As BSG mentioned actually, (thank you for that), it's related to the fact that we're using OpenGL, where as Unreal or Lumion is using DirectX. But, if you want to use RDP and have an NVIDIA GPU that is not one of the Quadro models, then there is now a special tool for GeForce GPU's to accelerate Windows Remote Desktop streaming. You will have to make sure you are using the R440 GeForce drivers or later. Download and launch the executable as administrator on the Windows Desktop where your OpenGL application will run. A dialog will confirm that OpenGL acceleration is enabled and if a reboot is required.

    Did you try this?

    That's a good question of course, thanks a lot for asking.


    As BSG mentioned actually, (thank you for that), it's related to the fact that we're using OpenGL, where as Unreal or Lumion is using DirectX. But, if you want to use RDP and have an NVIDIA GPU that is not one of the Quadro models, then there is now a special tool for GeForce GPU's to accelerate Windows Remote Desktop streaming. You will have to make sure you are using the R440 GeForce drivers or later. Download and launch the executable as administrator on the Windows Desktop where your OpenGL application will run. A dialog will confirm that OpenGL acceleration is enabled and if a reboot is required.

    This is a great news!

    I'm sorry to hear about that. Perhaps re-installing Enscape could already help with this issue. Please uninstall Enscape, then reboot the machine, run the Enscape installer again and in the first window of the installation process, where you will see the checkbox named 'I accept the terms in the License Agreement' make sure that is checked. This will enable the Advanced button which you should then click to proceed to the next window which will offer you the option to install for all users of the machine.


    If that doesn't do the trick, please also send in a feedback report if possible. :) Thank you in advance!

    I had tried this on that day and it is now fixed. GPU driver also updated during the process.

    Since some people are waiting for this anxiously,


    You can copy SketchUp 2019 plugins folder's Enscape into SketchUp 2020's.

    This does pose an error at the beginning that you can just say 'no' to.


    FYI,

    C:\Users\<username>\AppData\Roaming\SketchUp\SketchUp 2019\SketchUp\Plugins

    Copy both 'enscape' folder and 'enscape.rb' file, and paste into:

    C:\Users\<username>\AppData\Roaming\SketchUp\SketchUp 2020\SketchUp\Plugins


    This is a manual way of copying extensions and plugins for SketchUp, and I am not responsible for any mishaps in this method!

    BIG&GIANT* This is not a legitimate way of using Enscape. If you want to do the safe way, wait for Enscape's official release!

    But I have been using Enscape in SketchUp 2020 this way since the release :)

    BTW, I did not know that was the limited issue with the preview version.

    Thanks for letting me know!


    I think promoting the arrow keys to prevent the accidental CTRL+W is fine.

    Simply removing CTRL key functionally wouldn't prevent people from accidentally hitting CTRL+W because of the muscle memory.


    So, I think it is a fine implementation!

    I know the reasons for disabling WASD keys on the web standalone,

    but I think it should display the arrow keys on the 'hud' instead of the WASD to not confuse people.


    Also, I have noticed that the hud is disabled by default if you have that setting enabled from Enscape.

    It may be beneficial to set that independent to the regular Enscape viewer vs web.

    I personally find Enscape's 4k resolution setting a bit confusing.

    I would prefer to have '2160p' or 'UHD' as the name, and have 3840x2160 pixels of resolution.


    Enscape always had 720p, HD (1280x720), and 1080p, Full HD (1920x1080), and well received. They are both 16:9 ratio.

    The logical next 16:9 resolution to support is, UHD (3840x2160). If you litterally double 1080p, it becomes 3840x2160.


    But, instead, Enscape supports 4096x2160, named 4k, which is 17:9 ratio.


    If you do a bit of research in this, 4k is technically correct to have 4096x2160 as is a TV standard. But, is not used very much, especially in computer graphics and videos.

    See YouTube's settings as an example:




    Consumer TV's and computer monitors rarely have actual 4k, 4096x2160 as the native resolution.

    Instead, they just market by saying 4k UHD, to confuse their consumers even more confused.


    *I don't know why Enscape also decided to support 1024x768, as it is quite random, but less concerned about this.


    I kindly suggest to include '2160p' or 'UHD' (3840x2160), in the resolution option and keep current '4k' if you want to be technically correct.

    or,

    Maybe you can overhaul the resolution settings to include setting the image ratio, and pick some standards from very useful image below:

    https://upload.wikimedia.org/w…_Video_Standards8.svg.png


    And yes, I know, I can just set to 'Custom' and set resolution to 3840x2160. Just saving your keystrokes here :)

    Hi Demian,


    I was just replying to you comment:

    ...since SketchUp itself doesn't allow the assignment of materials to "face me" or "always face camera" objects in general...

    and prove to you that SketchUp does allow the assignment of materials to the 'face me' components.


    do you perhaps just wish to have the transparency get translated into Enscape?

    Yes, I want the transparency to be translated.

    I understand I can change the color, but no transparency can be applied.


    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Thanks for ensuring me that this is on the agenda. I understand that you cannot provide any ETA. I just needed to know if this hasn't got lost.


    Also, I had faced one occasion where I needed to have emissive material onto people, but also had realized that it isn't possible.

    Maybe this can be added to the same ticket if it isn't too tricky in terms of development.

    Not sure if I am understanding this Demian Gutberlet.


    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    I sure can apply the materials to 'face me' type of components.


    Do you mean that SketchUp itself does not allow materials in regards to APIs?