Posts by Clemens Musterle

REMINDER! If you encounter any issues with Enscape (e.g. crashes, installation problems) or your subscription please reach out to our dedicated support team directly through the Help Center or by using the Support button as detailed HERE! Thank you for your understanding.

    Hey IlseTanis thanks for your report. This was unfortunately a known issue of the Nvidia Denoiser integration for captures. It usually only occurs in very bright scenes.

    A workaround could be either to reduce the light brightness or to disable the Nvidia Denoiser in the renderer settings.


    This issue will be fixed in the upcoming 4.0 release! (Next Preview will also be shipped for Windows and arrive soon).

    This issue should only happen for rather rough metallic surfaces that are covered behind glass. If it's visually acceptable you might be able to avoid it by reducing the roughness of the material.


    Alternative would be to turn off transparent materials in reflections (which currently is enabled with hardware ray-tracing) via the userPre.cfg file:

    Code
    r_alphaInReflections 0

    If you add the above it should not be visible anymore either, but you lose reflections of transparent objects in mirrors etc.

    Hey ViggoPaulman


    you might be interested in our blog post & webinar on the topic:
    https://blog.enscape3d.com/enscape-nvidia-dlss-support

    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    DLSS, to be very blunt and simple, is an AI "interpretation" feature by NVIDIA, that analyzes your scene and adds in its own frames in between the frames produces by the software [...]


    That's not entirely accurate for the current Enscape (DLSS 2 based) integration, but a specific feature of DLSS 3 called "frame generation", which we haven't adopted yet.
    DLSS in Enscape is only upscaling the contents of the frame at hand, but of course since the GPU can render in a lower resolution you can already get a notable speed-up thanks to that.

    DLSS will be active for walk-through and video rendering. Still images do get up-scaled if DLSS is enabled, but this up-scaling doesn't need the neural network as it's much simpler and can be solved without it. In theory there can be minor visual differences (in screen-space effects) due to the up-scaling, but usually still images are almost identical to the native resolution results, as you've noted.

    For video renderings your results may vary: 2 years ago when we first shipped it, DLSS video quality was usually even superior to native resolution rendering, due to our temporal anti-aliasing implementation, which couldn't compete when it comes to sharpness/ghosting for fast camera movement.
    However in the mean-time we've replaced that temporal anti-aliasing implementation with AMD's FSR2 algorithm, which delivers much better quality.


    Bottom line:
    If you want best possible quality in your videos and don't have any issues with limited VRAM or long rendering times, deactivating DLSS makes sense.
    However if you're doing e.g. 4k or even higher resolution videos and you risk running out of VRAM and rendering times become a bottleneck in your process DLSS usually doesn't degrade quality notably even compared to the native resolution FSR2 temporal anti-aliasing we have today.


    And generally if you need fluent frame-rates for smooth navigation in your real-time walkthroughs it makes a lot of sense to have it enabled, especially on high-resolution (4k) displays.

    Hope that helps!

    Hi wlam


    What you have here is very likely so-called z-fighting (https://en.wikipedia.org/wiki/Z-fighting): Two surfaces are placed in exactly the same position or extremely close to each other. Renderers are in this case unable to decide which surface is visible to the camera in a coherent way.
    You need to either delete one of the surfaces in your CAD program or move the overlapping surfaces away from each other.

    Hope that helps!

    Hey olidesign, thanks a lot for your report. Can you clarify which Enscape version you are using (you can find that info in the About window)?

    In case this is the latest v3.5.6 release: In this case there's unfortunately a known issue with usually very bright scenes. Two options that you can do to avoid this noise in this case:

    • Reduce the (sun & artificial) light brightness in the visual settings and see if that resolves it
    • Disable the "Nvidia Denoiser" in your renderer settings.

    If it's not 3.5.6 or the above didn't help, then the problem is likely rooted in the scene setup with the entirely black skybox. It seems that the noise isn't visible in the setup with the default sky.
    Instead of using the black skybox I'd recommend using the mask export feature to have an image without the background and just change the day-time to night for your renderings.

    Thanks a lot for your report. Looking at the images I think that's not a denoising problem, but probably the emissive(?) geometry not being visible anymore. This could be related to other changes behind the scenes that involve the data structures used for ray tracing.

    It'd be great if you can share the material setup of these objects (maybe try flipping front/backside?) or even share that section of the project with us, so we can investigate this further. Thanks!

    hbc_visual Thanks for your report! It looks like a problem we've already had other reports on and which is currently being fixed. Unfortunately there's no good workaround I can offer at the moment. It seems the problem doesn't show without the white mode in this scene, as the bounce light isn't as bright in this case.

    Good news is that we plan to release a Service Pack soon which comes with a new denoising solution for video captures, which solves those issues as well.

    Thanks for confirming! I could reproduce the issue now also and will create a bug for it.

    Fortunately there's a workaround that should work well enough for 100% mirrors: Please reverse the face orientation, so the backside of it is facing the room and apply the mirror material to that. The backside won't receive the spot light's lighting in the reflection and thus it should render correctly also for multiple bounces.

    hypercube please send feedback with log files included and we'll be able to tell you more about what's going wrong.
    If things improved with turning off ray-traced sun shadows it's indeed hinting on that it might be memory related, especially if you have lot's of high poly geometry in your project. Another cause of high memory consumption with rt shadows is animated vegetation (as it requires unique geometry for each animated asset) - setting wind strength to 0 might also help in this case.

    Paul Russam glad to hear you're seeing improvements. There have indeed been a lot of quality improvements exclusive to hardware ray tracing in the last releases :) It does require more memory than the software ray tracing implementation, as it simply considers more geometry for GI and reflections.