Posts by pibuz

    Oh, I figured it out. The texture coordinates in the Enscape material editor are behaving weirdly - when switching the texture scale from 19 meters width to 1 meter, you can see the texture - but there's something behaving inconsistently. I'm checking further and letting you know.

    Maybe it's this! Thanks for having tested it!

    BTW in my experience the texture applied to the group doesnt show up at all, it's not that it's scaled or anything else...

    Hi again!

    I watched your video but it seems like you actually didn't do everything as I did. You took a checker texture and did not make a fitting texture. Don't know if this would affect the behavior, but it's worth a try.


    Also, your checker texture itself is acting weird: being a cylinder you should get a perfectly mapped texture, but I don't know why.


    Try making the two textures!

    Hi Kaj! Thanks for your reply.

    I already had an issue like this, and I already told you guys what is the procedure to reproduce this behaviour. Since I had no answer to the other thread, I thought it would be useful to send a simpler case to analyze.


    Basically I see this is happening when you PREmap a surface. PREmapping is useful when you want the possibility to give THE GROUP a texture and see it correctly mapped on the inner faces.


    To reproduce the case:

    1. make a circle and extrude it to a cylinder say H100, delete the upper and lower faces;

    2. measure the circle lenght and prepare 2 textures in photoshop which have to be "lenght"x100. Prepare two different textures to clearly see the difference when you apply the two materials;

    3. Apply one of the textures to the circular face; it should match completely the face. With the face selected open the entity info panel, and change the front face material to default; now you have PREmapped the outer side of the circular face;

    4. Triple click on the object and make group/component.

    5. Now, if you apply materials to this group you will get a correct mapping of the outer face, as long as the dimensions of the texture of the apply material match the "length"x"H" dimensions of the face.


    This group/component is extremely useful when using Dynamic Components so we use this a lot in our firm. Hope it's all clear!

    I am trying D5 as well. I really like the behaviour of materials, especially mirrors and transparent, but I really enjoy the proxy feature of Enscape, which I don't think it's implemented in D5 at the moment..

    Hi! I'd like to reply to the 2.7 FAQ thread but it seems there's no way to do tha, so I'm creating another thread.


    The new "orthographic render" feature is wonderful and I could use it a lot, but I really think it should be implemented in the form that it's automatically activated when the modeler switches the current view to orthographic. So basically if I set the sketchUp viewport to be orthographic, I get an orthographic Enscape view. :)


    Do you think it could be feasible in short times?

    Hi Demian, sorry for my late reply.


    You know that in sketchup is possible to apply materials to groups/components, but in this case you cannot control the mapping. In these cases there is a special workflow which allows the user to have a nicely mapped material, I call it pre-mapping.


    So:

    1. you make a whatsoever group/component which is default white;

    2. if you now apply a textuerd SU material to the group you get a "default" mapping, which rarely is the one you want; undo the operation and restore the default white;

    3. Enter the group/component until you see faces. Apply the material to the faces you want to be mapped, apply the textured material and actually MAP the texture onto the surface(s) with the standard SU tools for mapping;

    4. when you're done, select all the faces you have mapped and open the ENTITY INFO panel;

    5. you will see that the you have a small icon representing the material applied to the faces; click over the thumbnail representing the applied textured SU material and choose the default SU material again; in this way you get your white faces back BUT you don't loose the mapping;

    6. If you now exit the group/component and apply the texture to the group you will get the correct mapping onto the faces you have PREmapped.


    Hope this helps!

    Sure! Here it is!


    first time I encounter this issue. I have to say that I premapped the component for making possible to make a dynamic component option available.

    Don't know if this operation messes up some Enscape settings.

    ...hmmm...what you say is odd, mostly because you're saying that currently Enscape should behave as I'm expecting, which is actually not happening.

    I'm going to investigate further if I'm doing something wrong! Thanks in the meanwhile for the clarifications!

    I never said I want them to be independent one from another :).

    I just said that the DOF parameter should define an interval between two planes, not a single plane. The higher the number of DOF the wider the gap between the two planes.

    The positioning of the center between the two planes should be either defined by the user, or left "automatic" as an option (as it is now, which is cool). This way we can have an actual control over the objects in and out of focus. :)